The workshop doesn't work anymore

I have recently tried to uninstall my mods in order to test the incompatibilites of the Departement of education and families mod. The game stopped working (getting stuck at please wait). So, I deleted it and downloaded it again.
And now, for some reason, the only mod that the steam workshop is willing to download is the Departement of education and families mod. Any other mod just won’t download. I tried various things like refreshing the steam workshop, unsubscribe and resubscribe and so forth.

I have exactly the same problem. Can anyone help us?

I’m running Windows XP.

Removing the folder will not prompt steam to redownload the mod.
First before you do this try letting steam verifying your local files to make sure that you haven’t removed any vital files to the game.
To do so right-click Democracy 3 in the steam-library.
On the local files tab click Verify integrity of game cache.

Then see this post on how to force steam to update the mod.

Can’t locate mod_date.ini