Tried to make a mod - Something isn't working out

Today I thought I’d try my hand at making a mod but for some reason it won’t show up in game and I can’t seem to understand why. The mod just simply adds two policies, and I know its not a problem inside the CSV file. I think the mod issue has more to do with pathfinding or the mod being in the wrong folder or something of the sort. From the picture I inserted you can see the path to where I put it. Please let me know if you need more info to tell me what the issue is. Thanks!

The main folder should have the config.txt along with any and all subfolders from steamapps/common/Democracy 4 that you are adding to.

You will also need a translations/english/policies.csv to store the text that your policies will display to the player.

an example hierarchy to add a single policy would look like:











I tried to follow but I still think I’m doing something wrong

does data/simulation have the policies.csv?

otherwise looks good to me.

simulation/policies.csv should have lines like:

english/polices.csv should have lines like:

data simulation has the policies.csv

The policies.csv in translations/english wasn’t correct but I fixed it however that didn’t fix the policy appearing. Is there a problem with my config file perhaps

Could you try setting the path to C:\This PC\Documents\My Games\democracy4\mods\OverhaulTest

just tried that, it didn’t work

Everything seems right to me. Have you tried downloading one of the mods from the steam workshop to try and compare?

I have but I can’t seem to find the pathing towards it since those don’t show up in the “mods” folder in order to compare

The mods from the workshop are stored in <Your_steam_install_location>\steamapps\workshop\content\1410710

Unfortunately steam gives them random numbered names so it’s hard to look through manually. :frowning:

Democracy4 checks both locations for mods

Can’t find it, I think ill just wait until a modding tutorial pops up on youtube. Thanks for all your help :grinning: