Trouble Starting Game


#1

Hi! I recently installed the GSB demo (version 1.33) through Impulse on my computer and whenever I try to launch the game I get this error “Failed to initialize 3D Engine:…\src\Game.cpp 288”. I am sure it is not a problem with my graphics or resolution. Any help trying to fix this problem would be greatly apperciated.


#2

The game writes debug files to:
\my documents\my games\gratuitous space battles\debug
or
\program files\gratuitous space battles\debugdata

You can email those to cliff@positech.co.uk, or paste their contents here.
It’s likely a video card capabilities or driver issue.


#3

I have the latest driver for my graphics card, so thats not the problem. I think it may be a problem with the prefs.ini file, which is completely blank. Also, thanks for the reply.

ERRORS:

13/3/2010 - 4::40 - D3DERR_INVALIDCALL
13/3/2010 - 4::40 - software vertex processing failed
13/3/2010 - 4::40 - Failed to initialise 3D Engine:…\src\Game.cpp 288
13/3/2010 - 4::40 - D3DERR_INVALIDCALL
13/3/2010 - 4::40 - CreateDevice
13/3/2010 - 4::40 - D3DERR_INVALIDCALL
13/3/2010 - 4::40 - software vertex processing failed
13/3/2010 - 4::40 - Failed to initialise 3D Engine:…\src\Game.cpp 288

Its a lot longer than that but thats basically the whole error log.


#4

what video card do you have? it looks like it wont even run the game in software. I suspect something fundamental is wrong somewhere. You should have a prefs.ini.


#5

I have a Nvidia 7800GTX. I was also wondering the proper way to edit the prefs.ini file, because I think that may be the cause of the problem.


#6

Alright, I managed to actually get the demo to start now, but unfortunately when the title screen appears, the game crashes without an error report.

EDIT:

I changed the resolution to something a bit smaller and set windowed=1, and the same thing happens but now I get an error.

“14/3/2010 - 20::21 - ERROR - FMOD[Failed to init FMOD] (58) Error creating hardware sound buffer. :…\src\GUI_Sounds.cpp 635”


#7

That implies your sound card drivers are faulty. Are you sure you dont have some malware/virus? you seem to have multiple issues there.


#8

I do not have any malware or viruses. I’ll check my sound card drivers, thanks again for your help and suggestions.


#9

Hello I’v got a similar thing going on. I get This error message “Failed to Initialize 3D Engine:…\scr\Game.cpp 286” not too sure what this is.
I’v hade the game for abought 2 mounths and it has been running fine up till a few weeks ago. Any help on this one would be nice.


#10

what video card do you have?


#11

ATI Radeon HD 3870. With Driver Packaging Version 8.671-091104a-091527C-ATI
This is the same drivers that I’v been useing for some time. And its the drivers that I was useing when it was working. Also I got the game trow Steam. Not too sure if that makes any difrence other then the location of the files.


#12

I’v just got the newest drivers for my video card and there is no change I still get the same error meassage.
Any othere help on this would be nice Thanks.


#13

if you ditch this file:
mydocuments\mygames\gratuitous space battles\prefs.ini, and then run it, it should default some options. Does the game run then? It might be a video memory issue. You could also try turning off transitions and shaders by editing
mydocuments\mygames\gratuitous space battles\config.txt

SHADERS = 0.00
TRANSITIONS = 0.00


#14

Thanks got it working by the first thing that was deleteing that one file, Thank you vary much. I’v been realy in to the game and could not play it. Thanks