¿? ¿Turret maping not found???


#1

I just was finishing my mod, just placed the unlock costs for every module and when i launch the HQ FLEET, it continues crashing with a “turret maping not found” error. I really dunno how to solve it since the mod installation is perfect and the mod was working great until i placed the unlock system on the modules. Any ideas on wat should be wrong??? the problem is not 1 module cuz it happens on every module of the mod. But as i said, the mod is installed like all the mods around there xD (and it was working great without unlock parameters). Maybe is another bug?

I dont know if there is something with the error msg: Turret mapping not found [turret_armaggedon] ==> [federation]:…\src\SIM_Race.cpp 222

And in the race file it says clearly:

turret_armaggedon = turret_armaggedon.dds,concordium turrets.dds,6

so, im really lost here.

Maybe the game is searching for the turret mappins on another race directory but y??? i was using the same mod without the unlock restrictons till now and without any problem…
maybe it is not possible to make custom lockable modules???


#2

Have you create a picture named turret_armaggedon.dds in your turret directory? (an 128x128 pixel picture of the turret alone)


#3

If u read my post, the problem is not the dds (and the mod was working perfect only without the unlock parameters so the problem is something about that), btw if u dont have the dds, u will get just a blank spot but the game will not crash (and if it crash the error msg will not be the one i showed above). The problem is the game tells me that i dont have that turret mapping on the race.txt file, when thats not true. So the problem is a bit more complicated than that and thats the reason im desperating trying for help, cuz i checked all 100 times and i still dont know wats the problem.

I hope Cliffnski see this post and can tell us something about, i cant do anything more and im afraid i will leave modding on GSB if i cant figure this out (there is no sense for me to do a mod without unlock restrictions).

Thx for the help anyways.


#4

The problem is that in the Fleet HQ screen, the turrets to unlock use the federation turret mapping. That means that if you create a new turret class (in your case turret_armaggedon) and lock a turret with that class, the game will crash beacause the federation race file doesn’t have that class of turret mapped.

Darkstar solved this in his mod adding a modded version of the federation race file, but later he scrapped that because updates replace some of the original files. You’d better leave unlocked all the turrets using new turret classes to avoid problems.

Hope I helped ^^


#5

Thats precissly the thing I dont want to do, cuz i want the turrets need to be ulocked, thats one of the cool things in a mod, but as i imagined, theres is no way we can make a mod with locked turrets… thats really sad xD. I only thinking on updating the mod everytime a patch is out but thats ridiculous xD. I think i will stop modding till theres a real update. BTW i cant apply the last 1.47 patch either so… too many bad things in a row. I will try next month to see if something changed. Thx for the help.


#6

I’m not sure if it would work, but setting the federation race file attribute to “read only” ought to make the installer overlook it during an update.
In fact I’ll try this myself. I ran into this exact issue recently with my mod.


#7

I finally decided to directly modifiy the federation race file adding my mod turrets. If for some reason that file is replaced due to any patch, i just do the same thing again, its not a big problem. BTW i finally patched the game to the 1.47 version and the changes i made are still there ^^. So for now, thats my solution. I dont want to set the file atribute to read only, cuz some updates add turrets/modules in some cases and the update need to replace the race file. So the patch will not be installed correctly. I prefer my method :wink: and btw sorry for my previous post i was a bit angry … just a bad day :wink:

Thx for the tip anyways.