Two Outcast expansion errors


#1

This is the first expansion that I’ve bought. Loved the original game.

I can design and setup everything with Outcasts, but I can’t do 2 things: Once I press the ‘fight’ button, this error occurs:

ERROR – FMOD[Failed to createStream] (23) File not found.:…\src\GUI_Sounds.cpp 661

And when I try to access the ‘Fleet HQ’ menu, the following error:

Turret Mapping not found [turret_holo] = = > [federation]:…\src\SIM_Race.cpp 249

I’ve read some of the common bug fixes on this forum, but they don’t seem to apply. Could this second one be cleared by just reinstalling the base game?

Thanks for any help you can provide.


#2

First one is obviously a missing sound file, apparently GUI. I think GUI may just be a general label though, so it could be you’re missing a sound effect or even the Outcast’s music. (the latter only plays when using that race).

As for the Fleet HQ, it’s a common issue during modding. The Fleet HQ displays the version of turret the Federation uses. Problem is that the Federation doesn’t have a “turret_holo”, but the Outcasts do. There is was a simple workaround, but it seems that it wasn’t used.


#3

The odd thing is that I went straight to Fleet HQ and unlocked all the new Outcast goodies, and didn’t have any problems whatsoever. Particularly odd since the Outcasts have not one, but three turret IDs that are not included on the Fed list (which seems to be where Fleet HQ and the stats screen pull their primary mapping from). And I don’t seem to be having any problems looking at them in Fleet HQ now either. Given what (little) I know about how GSB handles that sort of thing, I would have expected to get exactly the error you’re having. Strange.

What version of the game are you running, and did you get it straight from Positech or through Steam? (I ask because sometimes these things matter.)


#4

Strange indeed.

I’m suggesting an Outcasts re-install and see if the issue is fixed.


#5

Thanks a lot guys. I should of checked the version before posting. I had assumed that the expansion would trigger any possible updates.

I was on version 1.56 if anyone was wondering. Everything seems to be working fine now that i’m up to date.


#6

That would explain it. Support for Outcast tech wasn’t even introduced until 1.61.


#7

Hello, all

I’m new and this is my first post. I wanted say that I too have this problem with not having the" [turret_holo]===> federation " thing. And this guy seems to have fixed his problem buy just downloading the update? So how would one go about doing that??? I bought my game from Impulse before it became gamestop and yes i have updates, my last update was from 11/2/2012 . But for some odd reason gamestop didnt have the current Outcast DLC so i bought that from positech games. and a bunch of transferring files here and there later I pretty much copied the the whole outcast DLC onto my gamstop’s GSB. Everything seemed fine until i realized that all the outcast new weapons were in the Fleet HQ so i clicked and you know blah blah blah error. So i need help .

Thanks to anyone who read this at lease.


#8

What is your version of GSB?
(version number in the top right of the title screen)
Reason why I ask is that there have been some updates since 11th Feb 2012. (or 2nd Nov 2012) . . depending on your format

As mentioned earlier, its a turret mapping problem with the outcasts
Fleet HQ use Federation turrets in GSB versions 1.61 or earlier (IIRC)

From the Bugfix and development feature list (changelog)

If your version number is less than 1.62 what you need to do is ensure that you have registered your version of GSB online. (The online button in the game)

From there you will need to force the game to update.
One option is to close the game, advance the system clock by 1 day and restart the game again.
The other is to navigate to \My Documents\My Games\GratuitousSpaceBattles\web\ and delete the up file.

If that fails, re-download the game from where ever you bought it.


#9

Here’s the weird part , I do have patch 1.63 but when i try to run it and then open the GSB app it go’s white screen?? And by the way when you said system clock thing, did you mean set the system clock back by one day or forward one day, because I think its impossible to set it forward one day. Also Is it possible to install the Outcast DLC from Positech Games to GSB from Gamestop? Because I extracted everything from my PositechGames outcast DLC and inserted it into my GSB Gamestop edition manually. Everything worked out find until again i mentioned that the cool weapons were in the glitched FleetHQ store.


#10

OK , thanks for the help and the care to read my reatarded-ness darkstar076. As it turns out all i had to do was install the patch to my Gamestop GSB , see i for some reason i have two copy’s of the game one from Positech and the other I just said. So that’s why… See this is why you don’t try to trouble shoot your game problems at 4:00am in the morning, I ran out of logic.

Anyways thanks :slight_smile: .


#11

Ok one more problem and I’m set to sail out of here . My Outcast solar power generator has no image… It works but there’s no image of it its just i blank white picture of it . I recopied and recopied from the outcast module file and put it into the GSB module file but no avail. Is there a specific fleetHQ file that i can go into and fix this problem?


#12

If your solar generator is being displayed as a white square, that means the game can not find the image.

After you have installed the DLC, In your main game you should have the following path.
\Gratuitous Space Battles\outcasts\data\bitmaps\

In there should be about 4 sub directories and six files.
One of those files should be module_power_solar.dds

If that file is no there, then you have found a reason why the module appears as a white square.
All you then have to do is go find it and place it back where it should be

One thing i do not get is why you have to copy the files across manually. I am assuming it has something to do with the Gamestop version having a different installation setup


#13

So where exactly is the place I put this file? Because I found it. Oh and yes Gamestop GSB is different and pretty much in there UDI i would have to buy the DLC’s from them directly for it to go smooth sailing in the installation process . Put they don’t sale Outcast DLC sooooooo yeah…


#14

Never bro I fixed it that was a stupid question above. Thanks for the help and time wasted lol… I would send you a virtual beer if I could.


#15

Your most welcome for the help, its what we are here for.
I don’t consider it time wasted to get someone up and running with GSB.


#16

Hello friend were you able to fix the problem? I am facing similar issues so can you shed some light to help me out? Waiting for reply thanks in advance:)


#17

As far as I am aware - Yes, the issue was resolved.


#18

I was not able to find any solution for this… My power generator did not had any image…Were you able to sort it out? Waiting for reply.


#19

On the first page of this thread you will find this possible solution - if you could please try it and let me know how you go.