Unable to play Campaign


#1

Afternoon folks,

Picked up the galactic conquest dlc today and registered ingame through the online section, confirmed code valid/username accepted. However when attempting to play the campaign I receive the message

Get the message: “Login Failed! Either your PC is not online, your firewall is blocking the game, or your serial number is not valid. Please check and try again.”

Internet is definitely ok and there’s no firewall issue (I’ve disabled to be sure). Also tried restarting. Any suggestions?

As an aside - my challenges list is empty. Tried refreshing but no results.

Cheers in advance


#2

the code is in this format:
XXXX-XXXX-XXXX-X
Is that what you have put in? (do NOT type it here).
If it is, then it is DEFINITELY a network issue of some kind. That error generally means something blocking the game. Are you running it in a window? If you do, you might see an otherwise hidden windows message telling you the game is trying to connect.


#3

Hi Cliffski,

Thanks for the reply. My key is in a slightly different format to the one you’ve shown (2 additional characters in 3rd block)
XXXX-XXXX-XXXXXX-X Although it does demonstrate the 'Code valid. Thank you.

I’ve tried running in windows mode to be doubly sure but there’s no error message other than the one shown ingame.

There’s definitely nothing windows side that would be blocking the connection - could this be router related perhaps, is there a particular port which you use?


#4

Okay, I seem to have gotten around this.

I had to resubmit the code ingame and then retype/submit my username - very odd but all seems fine now!