Update issue

I can’t update my game to the newest version.
Update gets downloaded and unpacked, but the game just closes instead of restarting.
When I first tried to update I got a message from ad-aware saying it had deleted the updater, so I turned ad-aware off, along with my anti-virus, but still same issue.
I’ve tried launching in administrative mode, doesn’t help either.

The error log is as following:

[6/7/2015 11:18:10 AM] System.ComponentModel.Win32Exception: Access is denied.

at System.Diagnostics.Process.Start_shell (System.Diagnostics.ProcessStartInfo startInfo, System.Diagnostics.Process process) [0x00000] in :0
at System.Diagnostics.Process.Start_common (System.Diagnostics.ProcessStartInfo startInfo, System.Diagnostics.Process process) [0x00000] in :0
at System.Diagnostics.Process.Start (System.Diagnostics.ProcessStartInfo startInfo) [0x00000] in :0
at Launchie.Launchie. () [0x00000] in :0

[6/7/2015 11:19:11 AM] System.UnauthorizedAccessException: Access to the path “C:\Users\Ank\AppData\Local\Temp\Crafty\Big Pharma\updater.exe” is denied.
at System.IO.FileStream…ctor (System.String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, Boolean anonymous, FileOptions options) [0x00000] in :0
at System.IO.FileStream…ctor (System.String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize) [0x00000] in :0
at System.IO.File.Create (System.String path, Int32 bufferSize) [0x00000] in :0
at System.IO.File.Create (System.String path) [0x00000] in :0
at Launchie.Launchie. () [0x00000] in :0

Same here. Bitdefender was flagging it as a virus so I closed it after that the update will complete but the next time I launch the program it says there’s a new update and the cycle repeats.

Had the same thing. Also BitDefender.

Hello all, I’m really sorry for the inconvenience. It would seem every antivirus has its own criteria for whether something is flagged as malware. On Norton, Avast and Windows Defender there are no issues as far as I am aware.

I am looking into this and will report back as soon as humanly possible. The error logs are very helpful, if anyone else is having problems and has error logs please send them over.


This might not be an anti virus issue. The game actually runs on Linux with wine somehow decently but the update fails (game just quits).

Dunno if these logs help, as it’s unsupported linux with wine, but still who knows but you:

turned off norten 360 and updated normaly

Hi Tim!

My Norton is being a jerk about the update. I’m having the same general issue as the OP. However, I can “recover” the file after Norton deletes it. BUT then the game doesn’t use the file that I recovered, so it downloads a new one. (I even told Norton to exclude the file from detection or whatever).

So basically I’m stuck in a loop.

Thanks for your awesome support! I wish you guys were in charge of all game companies. You have the fastest, most reliable, and most down-to-earth support staff ever!

Having a similar issue, after unpacking update it just closes not restarts but my anti-virus has no reports of blocking anything and no error messages at all

mine didnt also but i turned it off for 15 minutes installed patch and it worked

Having the same issue. I also run BitDefender, and I have tried turning it off, and updates still don’t work. I know that when new versions of GSB2 are rolled out, they are at the same download link, but I am not getting an updated version to download from BMT Micro.

I have worked around the issue by disabling anti-virus, then restarting, then updating :slight_smile:

How do it get information for a new release to download (except for twitter news)?

for those using bitdefender and still having issues with updating, follow these steps:

  1. open the bitdefender main window and go to antivirus settings
  2. enter the “vulnerability” tab
  3. turn auto vulnerability scan off.
  4. restart windows
  5. start big pharma and update should work

I happen to have bitdefender windows 8 security

I had to go a bit further and disable the main antivirus, not just vulnerabilities but it worked in the end. Really debating getting rid of Bitdefender once my subscriptions up, more hassle than it’s worth honestly. This isn’t even the first program this week it’s false flagged.

I did just that, uninstall BitDefender to get it work. After I had done that, the update worked just fine.

My subscription ends in a few days and like you, it’s caused a lot of trouble for a lot of other programs too. Definately going for another vendor this time.

I don’t like bitdefender UI, I’m probably going to switch as well.

Big pharma, killer of bitdefender subscriptions

Ha ha ha that’s hilarious.

Thank you everybody for being so bloody understanding. I’ve been tearing my hair out about this no update issue. So glad you were able to find a way around.

I’m going to contact all the antivirus vendors listed and see if they will whitelist the updater so no-one else has this issue in future.

As far as I can see, the only outstanding issue with the update is the linux/wine combo. Does Wine emulate the entire userdata structure? Because the updater is extracted to C:\users<usename>\AppData\Local\Temp\Crafty\Big Pharma\ before being run, so that could be causing the issue. Does this folder exist after the failed update via Linux/Wine?

If anybody else is having an issue please post it here and I’ll see what I can do. :slight_smile:

Hi, I have just purchased Big Pharma and it installed fine but it tried to updated and Norton SONAR blocked it, as I am on a shared PC I don’t wish to disable Norton, can you let me know when and if this has been resolved. I am very much looking forward to playing it :slight_smile:

Is it possible to release seperate exe versions of the updates, as opposed to having the game manage them, at least as an option? Would probably help with the false detection bit anyway