Utter n00b


#1

I’ve downloaded a couple of mods (the more policies and Greece mods) and extracted them to my democracy 3 folder but nothing has happened. I’ve shut off the game and opened it up again and still neither appear in the mods menu option. I’ve tried leaving the mods where they unzip and tried manually moving them to the mod folder if they didn’t unzip there but neither worked.

Can anyone help?


#2

That’s weird… Just tested here and it’s working fine.
Can you tell me what you have inside your “mods” folder? (Democracy 3\data\mods)


#3

I have the more policies folder and the text document for more policies and Greece Xietanu (the folder for this automatically extracted to the democracy 3 folder itself, I moved it into the mod to see if that worked but it didnt so I removed it)

Thanks for the help


#4

It should be working just fine… Do you have 2 versions of Democracy installed? ie Steam and GOG? Maybe you’re starting the “wrong” democracy install (it’s a really simple mistake to do,but happenned to me on other games already)


#5

I downloaded straight from the site so I don’t think so. It does seem weird :confused:

EDIT: just checked the savegame folder and that has all my saves in it so I guess that proves that it’s the right install?


#6

Oh well :c
Sorry but I don’t know what is causing that. Maybe try reinstalling the game?
Also,do other mods work fine?


#7

Thanks for the help anyway. This is the first time I’ve tried to add mods so I thought I might be doing something wrong. I’ll probably leave it for a while and see if anyone has encountered this before and if not I’ll do a reinstall.


#8

Ah I’ve figured out the problem! Today I applied one of the updates and realised it was installing it to a different folder than the democracy 3 one I’ve been trying to add mods to. After hunting that folder down I’ve found I’ve got one copy in program files and one in my games, the former is where the game loads from so installing mods there works (although past saves don’t seem to work).

Success :slight_smile: can’t wait to get modding