VALIDATION PROBLEM


#1

everytime i start the game it asks me to validate. After validation and updates it will not let me start a game. Very fed up with it. Good game but, now paid for a game I cant play


#2

Hi, what error message are you getting? I rpesume the game said the code was ok, and you got all the buttons to start a new game, options etc? Can you email me the debug files from the games ‘debugdata’ folder to cliff AT positech dot co dot uk.


#3

Hi. I had all the buttons at the bottom of the screen. I had to hit the new game button 2 or 3 times before it would work. Once I had selected a country I couldnt get any further. Button to start refused to work. Tried everything turned all firewall etc. Restarted pc, downloaded and reinstalled game ,still no good.

In the end gave up. Just tried installing today and it works. No idea what stopped it yesterday. Thanks anyway. Great game


#4

Hi, I have the same problem. I’ve played several successful games, and this just started yesterday. The only odd thing about my installation is its not in the default install folder “C:\Program Files\Democracy2”. I looked at the debug files and it reports “response,true,Validation reply true” and includes my serial number correctly. I’d prefer not to reinstall to fix it, but I guess that depends if anyone has a fix for this problem :slight_smile:


#5

Could you try running the game in a window? you can toggle to windowed mode (if your monitor is big enough) using alt+enter keys. I suspect its some bug to do with some other window, or the mouse not registering correctly where it is.


#6

Heheh, this just got interesting. For the record, I normally balk at being a developer’s free QA or beta tester. However, I really like this game and I realize you’re a one man show… so I’m happy to help out. I’m also a computer dweeb and its in my nature to solve problems, so we got lucky today. Sorry to be so negative, I know you’d rather just fix this problem and move on!

Anyway, here’s a more detailed problem report. I installed the game 4 days ago from today, worked great for 2 days. On installation, I entered my serial code, hit update and got all the right messages about validation and it even updated a bunch of text files (I assume those are tweaks for the events in the game). I played the game with a few crashes happening. The OS crash report would say it caused an error in the executable and it was shutting it down. I didn’t bother to look at those, as I’m a lazy git. I tried changing the compatibility mode the shortcut was set for to run under Windows 2000 mode, with advanced text services off. This actually worked (I don’t have much faith in uncle Bill’s solutions to Winderz problems, normally) and I was able to enjoy a few hours of totally loosing the election. **This actually may be the problem, as you’ll read later, so record any changes you make in case something goes wrong so you can trace your steps to help with the solution to the problem.

Then I encountered the validation problem. I played with it a bit, entering the software key again, taking it out etc. No joy. I kept getting the message that the game needed to be validated online, enter your serial number etc. Searched the forums, found this post and posted. I did try your suggestion to run in windowed mode by hitting ALT-ENTER, but did not solve the validation problem. One difference did show up; at the top of the validation screen the message that the game was validated online returned. Unfortunately, the rest of the game didn’t follow and from the main screen I only had the Validate button. After that, I had the epiphany that maybe the developer never thought a bonehead like me would fool with the compatibility mode options on the shortcut. I removed all compatibility mode options from the shortcut, and the game appears to realize once again it is a validated and properly installed game. I’m able to start a game again! Unfortunately, its 0830 in the morning for me and I have to head off to work. I will play the game as time allows and update this topic with anything new that may happen. My concerns are that the crashes will return, but we can talk about that. :unamused:

My hardware setup is as follows:
AMD Athlon 64 X2 Dual core 4600+
2 GB RAM, ASUS A8N32-SLI Deluxe motherboard, 2X MSI Gforce 8600 GTS running in SLI mode
My desktop resolution is 1280X1024

Software:
Windows XP Pro, SP2, latest updates, latest drivers for all hardware (I check this weekly at the least)
I do have quite a few programs installed and/or running that may be of consequence: LogMeIn, DaemonTools CD emulator, SpyBot, AVG AntiVirus, Windows Defender, Skype, Trillian


#7

Hi, I think I misunderstood the problem. You say that the game keeps forgetting its validated? That should NEVER happen, unless you log on as another user 9even then it shouldn’t) or you somehow mess up the windows registry.
I’m guessing from what you describe that the game is not reading the registry properly if you change the compatibiltiy stuff, but even that should be impossible because those functions haven’t changed since windows 95. I’m also concerned that the game is crashing for you at any point. I’m not aware of any random crash bugs in the game. The game does write out debug logs to it’s ‘debugdata’ directory, so if it crashes again, could you email them to me and I will take a look.
If you have any software which runs checks or clean-ups or something on the windows registry, i guess that may be causing issues. You should only have to enter the code once ever.


#8

I have a prob with validation too. Installed game, clicked on validation button, typed in the ID, clicked on update button, the program downloaded some files, validation was completed, back to main screen but instead of the servaeral menue buttons just the validate this game button appeared.


#9

Hi is this under XP or vista? and are you running as a limited user or the administrator?


#10

Vista. Administrator.

But I have to tell you that the problem is solved now. Don’t ask my how I’ve done this, I don’t know it… :wink: