Version 1.16 now released


#1

Ok, the game auto0-checks for updates once a day, but if you just missed it, you can either…

re-use your original download link from BMT micro and grab a fresh clean installer, which is now version 1.16
or
Delete the file called ‘up’ in \my documents\my games\gratuitous space battles\web
Then run the game.

If you have a fast connection you might get it faster from the BMTMicro link than our soon-to-be-swamped server :smiley:
Any problems specific to updating between the two versions, please reply to this post, or by email.

Changes:

[code]Version Beta 1.16 Feb 11th

  1. Fixed crash bug if non-admin on first caching of AI ships.
  2. Fixed crash bug when going to create a enw design from the deployment screen, if non-admin.
  3. Armor that consumes power now displays this stat correctly.
  4. Fixed alt-tab corruption issue from design screen.
  5. Fixed bug where some beam weapons stopped working mid-battle.
  6. Fixed various glowy/rendering issues relating to non-modified ships hulls, or ships in certain design configurations.
  7. Fixed bug where some particle effects from engine glows did not display correctly on the ship editor.
  8. Fixed bug where steam thought game was Democracy 3.
  9. Fixed a number of graphical anomalies when a large ship breaks apart on destruction.
  10. Fixed crash if game attempts to load a deployment that contains a deleted ship design.
  11. Ship design screen now remembers the last ship you were working on and re-opens it automatically.
  12. Battle tutorial and ship in-battle GUI tutorial popups now added.
  13. Ship design rotation speed now matches (hopefully) the in-battle speed.
  14. Some fixes to group-adjustment buttons on the ship design screen.
  15. Ship designer now hides color selections that are not currently applicable.
  16. Research screen now tells you what ship sizes a module can be used on.
  17. Asteroids can now be turned off under options.
  18. Balance: All dreadnought hulls cost increased by 50%.
  19. Balance: Dreadnoughts can no longer use any limpet launcher modules or multi-point tractor beams.
  20. Balance: The heavy pulse laser now has a faster firing time but slower tracking speed.
  21. Balance: Increased the weight and also damage of the Lightning Gun and Pulverizer Beam.
  22. Balance: many dreadnought firing arcs reduced.[/code]

#2

Just checked, and there’s no ‘up’ document in my GSB 2 ‘web’ folder. :confused: (Or my GSB 1 one, but I assume you didn’t mean that).


#3

Have you entered a serial code and username for online challenges? It only sues the online updater if you’ve done that. Sorry I should have said that.


#4

Yes, I’ve just checked and both my serial number and username were accepted a few days ago. This file wouldn’t happen to go by the alternate name ‘gsbcd’ or ‘gsbcdu’, would it? They’re both in the web folder, and maybe one of them has the wrong name?


#5

Hmmm, do you have steam running, if so, shut that down for a minute, as they auto-updater switches off if steam is running, that’s probably it.


#6

Steam is definitely not active at the moment. Booting the game just leaves me at the title with ‘Beta 1.15’ still at the top. Checking the web folder still does not reveal an ‘up’ file.


#7

Thats very strange, but in this case I’d suggest just re-downloading the installer, which is now 1.16


#8

I entered the online details and turned steam off to get it to work (previously did not look for it)

I would report that the servers appear to be swamped, 0% for the last 5 minutes, will check back in tomorrow :slight_smile:

Otherwise will try the installer option, although that will remove any progress??

EDIT: Perhaps a future patch could include code for the updater to “check” with the servers, if they are full, advise an update is available and will be attempted next login?

EDIT 2: I bailed out of the update (as it had stopped) When I try to redownload it, by deleting the up file, it doesn’t try to download, just creates another up file…


#9

That worked at least. The case isn’t quite closed yet, though - there’s still no ‘up’ file anywhere to be found.


#10

To get the game to re-download the patch.

  • Open the \My Games\GratuitousSpaceBattles2\web\up file and change the date to yesterday.
  • Delete the latest patch out of \My Games\GratuitousSpaceBattles2\patches\

I had a similar issue when i alt-tab to another screen because the download was taking ages due to my slow internet speed


#11

I only had to delete the patch that existed and it retried to download (no up file), still got “stuck” on 0%, will leave it for a while.

EDIT: Stayed on 0% AFAIK until it finished and installed. I knew it was working as I checked the update file size periodically.


#12

Just a weird thought, do you have a firewall in place ?

Only reason why I ask is that in GSB 1, there were some people who were not using steam and could not download patches due to firewalls.