Very serious flaw


#1

I’m on a gaming rig that has no problems running Starcraft-II at ultra-high graphics settings, so I doubt my system is the issue.
I downloaded this through steam, and designed a few ships, then tried to start the tutorial battle. I followed all the steps in placing ships and issuing orders. However, when I press the ‘save deployment’ button, nothing happens. nothing. no change whatsoever, it’s like the button isnt there. I can keep editing my deployment and whatnot, I just can’t save it. Load works fine, just not save.
Anyway, that’s not my main concern…

when I hit battle, it brings up a battle screen, but only my enemy’s ships are on it. They then vibrate very jerkily around in circles, while aparently they look for my ships to battle with. the top of the screen shows both fleets at 100%, and on the left, there are icons for the ships that I deployed, which I can press bringing up the ship window in the lower left. I can egen click on weapons and see the target range circle appear on the screen, but my ships are simply not there. The enemy ships jerk back and forth in place while slowly rotating and this goes on for inifinity (or until I give up and press admit defeat).

so… what’s teh deal?


#2

That is extreamly weird . . I have never seen that before.
Does the same thing happen when you deploy one of your own designs rather than the tutorial ships ?


#3

yup, doesnt matter.

I’ve never actually gotten to play the game. I guess I will be asking for a refund for defective product from steam?


#4

Apart from trying the standard solutions

  • Window mode at a lowwer resolution
  • turn off all the graphics details etc

This one has me stumped - but hopefully someone else might have a better idea.


#5

Sometimes the “Gratuitous Shaders” option can be a problem. Kill all exotic graphics options. Enable “Gratuitous Shaders” first. If the game will run correctly from there, then enable only one additional option at a time until you find the one(s?) that are problematic. At that point, you should have enough data to email to Cliffski so that he can smoke out the problem in the coding.


#6

this doesnt sound like a graphics problem so much as it sounds like your ships are never being loaded. Although tbh, the battle should be declared over in that case.
I assume you can position your ships fine on the deployment screen?
I also assume you dont get to see abny actual fighting? no lasers onscreen or anything?
The inability to save a deployment is also worrying, and make me think it is some sort of obscure file permissions issue. It really shouldnt be, but have you tried running the game as administrator on your PC? Have you got any ‘internet security’ software on your PC? This stuff is normally drivel which causes more problems than it solves, and if so, I’d try turning it all off, in case its stupidly preventing the game reading or writing files.


#7

I just installed this game today and have the same probelm of not being able to save my deployment setups. My battles are working fine but I am just unable to save deployment due to the button not doing anything as stated in the original post. This happens when trying to save single player deployments and online deployments, it is very frustrating to have to rebuild these deployments every time I play. I am not even sure what the “Mission” button is supposed to do but it does nothing as well. I saw another topic where someone said that these 2 buttons just don’t respond to clicks very well and that it can take 12 or so clicks to register 1 but I have clcked on the buttons 20 or 30 times with no results.


#8

yeah my mission button also doesn’t do anything but I assumed that was a function of the first couple of missions not having any special rules.

I’ve tried turning off ALL the options, to no effect. Also, I’ve noticed, when I’m on the battles select screen, where I can pick between the tutorial and one other battle (the rest are greyed out) there’s a picture off to the right side of that screen, it also seems to gently drift and ‘vibrate’ (for lack of a better description) like the enemy ships do when I enter the battle.

I can click on my ship icons on the left, and they appear in that little status-like box in the lower right, they even have names/etc, but they just never appear on the big screen…

I’ve disabled all security software, can’t run as administrator becuase I’m running it through steam and I dont see that as an option? and still same effect… you are correct that I see no battles at all, it’s a shame, becuase this game looks RIGHT up my alley, and screenshots have seemed super cool… I’mma try a different rig tomorrow and see if that has any affect.


#9

Some people, depending on video card driver are having that top buttons-clicking issue. Run the game in windowed mode, and it goes away. Its something to do with the windows titlebar thinking it is still there, when it clearly isn’t, and a fix has not yet been found because its very tricky to reproduce :frowning:


#10

ok windowed mode seems to have fixed alot of things…
My ships do fade in and the battle occurs now… however, it is like watching someone have a seizure. Things move and fire but spasmodically jerk back and forth, ie, a missile will fly, then suddenly jerk back to where it was a half second ago, fly a bit further and jerk back again, to inifinity. all the ships move this way and everything. I can speed up the game to watch it, but it still behaives this way, just faster…
everything on the screen jerks back and forth as one, so it’s not like each thing is doing it individually, it’s like the ‘time’ in the game keeps lurching backwards on itself repeatedly (again, I’m having a hard time even describing this phenomenon)


#11

I just bought the game today, and I have the same problem.

I was able to solve it by changing the processor affinity of GSB to only use one of my CPUs. This on a Athlon X2 3800+, running XP.


#12

Cliff:
I do believe above post is correct. I have been playing for a while, and have noticed that when I click a name that pops up in a dialog box during the battle, the windows arrow appears, and it behaves for a split second like a bar is there. I have a core 2 duo, and tried setting the affinity to one core. Voila, no more problem! And due to its low consumption of processing power, I can do so at full specs. I suspect that the OP has a veeeery nice computer, and is causing even more problems than my middle-roader. Please try this OP!
TO do so, ctrl-alt-delete, then right click the process, and set affinity to ONE cpu.


#13

Not sure if the Affinity setting will fix the OP’s graphics issues but it does not solve the issue of the Save Deployment and Mission buttons not working. I was able to load the game in window mode and that solved the problem but I am hoping this will only be a temporary workaround as I prefer the full screen.


#14

Will you please post specs?


#15

wow, I would never have thought it would be a multi-core thing. I guess my time-measurement code fails with some multi-core setups, although it’s weird, because one of my dev PC’s is quad core (AMD) and doesn’t have any issues. Are these intel machines?


#16

Mine is AMD, actually.
:confused:
But the reason I have any experience with this is SimCity 4. It would crash an hour into it because of my dual core setup. This happens to lots of games for various reasons and to various ends. Like I said, I had part of this problem, and I fixed it this way, so maybe it will fix it.


#17

I’ve had the issue on my single core pc, but now that I have a new quad core I don’t have it. Both processors are from Intel.


#18

Never had this trouble and I have a quad core at home. I wonder if i set it to one core if it will change anything. For the better of worse, as far as gameplay.


#19

The one I was having trouble with was an AMD 64 X2 Dual Core, I also tried it on my Intel Quad core and it ran fine (in windowed mode) on there. Once I turned off my other processor on the AMD machine, everything seems to be running as planned. Thanks for all the support, keep up the good work on this game!


#20

I win. :smiley:

Must be a dual-core only thing… >_<