Video resolution on Mac


#1

The game worked originally, but I evidently made a bad selection for changing the video settings in the options. Now when I open the app I get the background but cannot click any buttons. Actually I “can” sort of. If I hit escape it will bring up the “Really Quit?” screen. If I hover my mouse low and to the right the “No / Yes” options will highlight and I can click. Great, you can’t go “low and to the right” below the screen. I found where for windows you would edit the C:\My Docs…\my games… prefs.ini file to reset the resolution. Where would the equivalent of this be located for GSB on a Mac?


#2

The same place you find your ship designs? Sorry, not a mac user.


#3

Sorry about this; we haven’t had another report on the problem and aren’t sure what could have caused it. But it should be relatively easy to put it right. In (Home)/Library/Preferences you should have a folder called GratuitousSpaceBattles, and in there is a file called prefs.ini. You can open that in any text editor and change the height and width of the GSB window, and tell it whether you want to play in windowed mode or not (use 1 for windowed, 0 for fullscreen).

That should get the game back on track and then you can adjust settings in GSB itself.


#4

That fixed it. Much like the windows fix. I was clueless about where to find that .ini or if it would even be called the same thing. The cause? Me being stupid.

I have an external 20 inch monitor attached to my MacBook. With the MacBook display mirroring turned on the options tab within GSB provide all the resolutions available to not just the MacBook itself. Tip: Don’t select one that doesn’t meet the native resolutions for the MacBook monitor. I was hoping that in windowing mode I could drag it from the MacBook’s built in display to the second and then stretch it to fit vs have both displays adsorbed in the game. Evidently not.

Thanks for your help.