Voter group "Objectname" error


#1

I’m using democracy2/debugdata/drawdebug.txt to get the names of policies and stuff when playing around with creating new voter groups

So for example, if I want a voter group to respond to foreign relations, I use the name in the text file to make something like this:

CreateEffect(“foreignrelations”,“naturalized”,0.10+(0.15*x));

But then it gives an error. There are object names like “nationalservice” as they are put in drawdebug.txt that work and appear correctly in the game, but some others that don’t work.

Anyone has an idea what the problem is? Maybe the names in drawdebug.txt are not all correct?


#2

I use the CSV files in Program Files\Democracy2\data\simulation to get the names.

I’m wondering if the game is being case sensitive - try ForeignRelations rather than foreignrelations. I thought it wasn’t case sensitive, but I’ve just done a test, changing the case of the slider name for adult education subsidies to DEFAULT rather than default and the game crashed when I tried to introduce that policy. Thus you’re best to use the names from the CSV files and maintain the case (with capital letters where used in the CSV file). This is the only thing I can think of, as I used foreign relations (as “ForeignRelations”) in my voter group and it worked fine.


#3

It’s working now… I just deleted the file and began adding the createeffects one after the other. Maybe it is case-sensitive

Is there a limit to the amount of voter types though?


#4

You can only have three custom voter types in the game at any one time.