weird zoom bug please help


#1

The glitch involves me zooming in. When I am fully zoomed out everything is fine but when I zoom in a little bit white lines appear as well as some lag. Zooming in even further results in the entire background turning white and extreme lag. I just bought this game off steam and haven’t gotten very far yet but I’ve encountered the glitch at “lagoon nebula” and “encounter at Andromeda.” 'defending Sirius" doesn’t glitch and runs smooth at any zoom. I tried turning off every graphic thing in the settings as well. The attached picture shows the glitch at “lagoon nebula” map. I have a radeon 9250/9200 series agp (0x5961) and its total memory is 128.0 mb. I also have 1536 mb of ram.
If you need any more info just ask. Thanks

edit: I’m guessing it has something to do with the way the nebula maps seem to glow



#2

Reinstall drivers.
Reinstall game.
Reinstall BRAIN! Not really. One of those might fix it…
Inb4 Cliff pwns me.


#3

Reinstalled drivers =nothing changed
reinstall game =don’t want to unless I really need because I have lots of snazzy ship designs I don’t want to lose
reinstall BRAIN =I’m imagining plants vs zombies crossed with psychonauts :slight_smile:

additional info=I own all expansion packs


#4

All your ships should hang around, the game stores ship data separate from the game files.


#5

This could be the shader effect. You have tried turning off ‘gratuitous shaders’?
Bascially there is an additional level of graphics processing for some levels, such as lagoon nebula, which tints everything slightly yellowish in that case. Turning off shaders will reduce the amount of video memory and effects needed, and that may fix it, at the expense of a few specific visual effects.


#6

@ RCIX Will the ships stay even though I own the steam version? If nothing works then I suppose I’ll just reinstall it regardless and maybe just take some screenshots of my ship designs.

@ cliffski I turned off just ‘gratuitous shaders.’ I also tried changing resolutions, tried windowed mode, and I turned off every visual effect but the weird white thing persists when I zoom in. I agree that it is most likely a shader effect problem as my video card is junk (pixel shader 1.4 and vertex shader 1.1.) Are you sure that ‘gratuitous shaders’ removes the tint effect?


#7

Yep, AFAIK the ship and deployments data is stored separately no matter which version of GSB you have.


#8

Cool. I’ll uninstall/reinstall tomorrow (it’s 11:43 PM here in the U.S.)


#9

Reinstalled the game and nothing changed :frowning:


#10

I got a new laptop and now it works fine. Problem solved :slight_smile:


#11

I put it down to picking an ELO album cover as your forum pic :smiley:


#12

I have this as well, and can provide some hard data on the behavior of this glitch. Video card is a ATI Radeon 9200 series - I didn’t outfit this CPU, so that’s all I can give you before digging into the case and looking for a serial number.

This bug is a game-stopper; frame rate drops to 1-2 frames/sec when the screen is white. As you zoom in, lines appear, until the map (Background and starfield - the ships and weapon fire are still clearly visible) goes white. These lines are either horizontal, or vertical, depending on your map positioning. Vertical lines appear when when you move closer to the top or bottom of the map. Horizontal lines appear closer to the left or right of the map. The effect is harsher when you are in an area where you get both horizontal and vertical lines - you’ll get a white screen with much less zoom.

Screen resolution makes a difference; at lower resolutions, you can zoom in further before they begin to appear.

The white background isn’t instant - it fades in as you cross a certain threshold, but it fades in very fast. Framerate doesn’t instantly drop; I can’t tell if it drops when you cross a threshold, or just drops more and more as you zoom in further; I suspect the latter.

There are positions on the map where you can move that permit you to zoom in further, and in these areas, you can also zoom further in before the white screen shows up. This position is usually below and to the right of the map’s center, regardless of map size. Near the center of the map, you can usually find a place where the white screen actually appears before the lines, but you can still see the lines appear behind the white space.

If you are near this area at the middle of the screen, zoomed in to a point where lines and the white screen haven’t yet appeared, and move up, down, left or right, they’ll jump into place very quickly - zooming out again will usually remove them again.

On small maps:
(Tested on “encounter at andromeda”, 1024x768 resolution)

Remaining zoomed out will completely avoid lines and the white screen. You can zoom in a little with no problems, but you can’t even begin to see fine detail. If you begin to make out detail in the gun turrets, you have to be in the ‘sweet spot’ under and to the right of the center, where you can get the most zoom without seeing this effect.

On medium maps:
(Tested on “the orion ambush”, 1024x768 resolution)

Lines are visible fully zoomed out when your viewpoint is near the left or top edges. (This makes sense, because your ‘sweet spot’ is beneath and right of center - further from the upper left.) If you move the view to the upper-left corner, where you get both vertical and horizontal lines, the screen goes white, even fully zoomed out. In the lower-right, you have no lines at all, zoomed out.

On large maps:
(Tested on “the rockwall nebula”, 1024x768 resolution)
The ‘sweet spot’ is a very small region, and even fully zoomed out you will see both horizontal and vertical lines. Moving your viewpoint very far outside this zone causes a white screen.

Last and definitely least, I did not pick an ELO album cover as my forum avatar. :slight_smile:

EDIT: Tested all video options on this glitch’s behavior. No apparent effect. Drivers on the ATI card are recent, within the last two weeks.


#13

I strongly suspect this is just a lack of video card muscle, in terms of being able to load, and swap out all of the textures used by the game. Some stuff is only drawn when you zoom in, hence the extra workload on the graphics card.


#14

Actually, it seems to be linked to starfields. I’ve verified this, and can zoom in to the full limit, on maximum map size, with maximum screen resolution - as long as no starfield is involved.

viewtopic.php?f=21&t=5543&p=38237&hilit=+white+lines+#p38237

As to whether the card’s muscle is involved, very possible, as I’m having to make do with a on-board card. But this raises lots of questions, if you think this is the problem.

  • Why doesn’t the number of different ships present on the screen or map have an effect? Shouldn’t it be mitigated when there are very few ship types involved?
  • Why doesn’t decreasing video options (other than resolution) mitigate this, even a little?
  • Why should positioning the screen change the amount of load in the same way that zooming in does? On a large map, I can find one part of the screen, (always in the same place,) where fully-zoomed out, I have only a couple of lines and everything moves perfectly smoothly. If I pan out of that area, without zooming, I get the same effect.
  • What the heck does the starfield have to do with anything?

#15

Any more ideas on what might be causing this, which might correct it? I can fix this problem on any map by opening the map file and turning off the starfield, but it’d be nice if there were a fix I didn’t have to keep re-applying over and over again.


#16

The starfield is the only thing in the game rendered using a specific DirectX function (point lists), and it must be that certain video cards have bugs in that specific feature. The next time I patch the game, I’ll make the starfield optional.