White Background


#1

Hi,
I bought Galactic Conquest yesterday and tried out the campaign for several mins. Everything worked fine until i deleted the campaign and started a new one.
Then the background on the galaxy map went white. I’ve checked the campaign.txt and it refers to campaign_map.jpg as it should. The Jpeg file exists in the UI directory.
Is this a known issue?
Thanks


#2

It is, and it’s fixed using weird voodoo. Nobody knows what is causing it, but everyone I’ve spoken to so far has fixed it by:

uninstall and delete (or rename and back up) everything, the games install, plus the stuff under
\mydocument\my games,
then they reinstalled the latest version of everything, and it was fixed.
No idea how it happened, but apparently that fixes it. Let me know if you need any links reactivating, by emailing your email address you used in the order to cliff@positech.co.uk


#3

This fix didn’t work for me. Tried uninstall/deleting, then copying my data back into the two folders (Program Files and My Games).

Any thoughts?


#4

Did the fix you mentioned here and it worked great!

It appears that the 1.53 installer is missing that line re: the campaign_map.jpg


#5

In fact, I just noticed that when I exited and restarted the game that the white background was back.

Sure enough, I had to go into campaign.txt and reset the MapTexture.


#6

I have this issue too - I dled the whole game around 5 days ago, everything worked fine even on campaign but then suddenly the background disappeared and won’t return.All the files mentioned are in the correct places too.


#7

I have found that resetting MapTexture solves the problem, but every once in awhile I have to reset it.


#8

Sorry if this is a stupid question, but is there a certain way to reset it? As far as I can tell from looking at the text it’s still fine, is there something else I should be doing?


#9

Edit campaign.txt, setting:


#10

Gah. Just got whitescreen. So is the solution the same for a Mac?


#11

It may have something to do with the files in the following locations. gratuitous space battles/campaign/data/campaign txt “or” gratuitous space battles/campaign/data/encounters.

the reason I believe these locations may hold the key is I modded the map and home-world using these files. it worked fine for a while and then the white background appeared. I tried another back up of the game, and found it ran fine, but when I copied the encounters folder and campaign txt file to the backup location the white background reappeared.

I hope this is of some help.


#12

It has just happened to me again. it occurred after i changed back to full-screen (highest resolution) from windowed, and a lower resolution.


#13

I know when I check gratuitous space battles/campaign/data/campaign.txt when I have a white background, I notice that the MapTexture isn’t even in the file. If I put it back in and save the file (even while the game is running), when I start a campaign, the background is back.


#14

Holy cow, that sounds interesting. I’ve been trying to find out the cause of this, because annoyingly, it’s something I can’t replicate. You are saying the file is actually being changed while the game is running?
I shall investigate further…


#15

I don’t know if it’s being changed while the game is running (to clear out the MapTexture), but I know that I can modify it while the game is running.

It’s a most peculiar behavior!


#16

Aha, it changes only when the game is running! That’s the missing link I didn’t realize lol… When I next go on I’ll check and see if what happens to Bryan is the same for me, and post here. Will be nice to be able to see them stars again :slight_smile:


#17

OK…

I know what it is, and I’ll fix it today. I’ll also blog about my incredible…dense…mind numbing stupidity.

In the meantime, if you want to fix it, do not, when playing the campaign, ever hit the ‘H’ key. If you do, that file will get edited.
Yeah yeah… I know…


#18

Interesting…

Do tell!


#19

Can confirm that both myself and my brother who got the game yesterday have this issue and it’s resolved if we go into the txt file while playing like Bryan described.

Good that you’ve worked out what’s causing it, does that mean a fix will be added in the next patch?


#20

Yup and the patch is out now. Should roll out over 24 hours
basically, ocne you’ve fixed it, don’t press the ‘H’ key at any point… sigh
Once you have version 1.54, you can hit ‘H’ all you like.