whoops, I've broken my game!


#1

ermm so Ive been playing around trying to make some extra modules (text files) and now I’m getting a crash at start up that displays this in the background then exits>

“Module Type not found ->frigate power IV:…\src\SIM_ShipMpduleType.cpp 272”
or
“Module Type not found ->frigate engine IV:…\src\SIM_ShipMpduleType.cpp 272”

I guess its something to do with my new addons im playing with, but I dont know what? However after getting rid of all new modules and redownloading everything through steam I get the same thing again, except it points to existing modules with the same error.

Can anyone help me identify what this is I cant seem to get back in the game regardless of what I try to do, thanks :expressionless:


#2

Hello again, disorder. Are you having problems with an item that you modded yourself, or one originally modded into being by another player? I saw from the error message you posted that you were working on an improved frigate engine. Without seeing the exact code you have for that module, it’s hard to do anything except guess what went wrong. If you’d post that, perhaps we can help.

I also noticed that you are having trouble with a “frigate power IV” module, too. I have a “Type IV Power Generator” modded for frigates available here. Did you use that module and make subsequent changes to it? For what it’s worth, I just copied that same original code from my linked post and imported it into my copy of GSB. The game starts perfectly and allows me to save a ship design which uses that module, as well as use that ship in battle. Was it someone else’s code, instead?


#3

Oh hey thanks, I thought I tested yours first and found it worked and that gave me the idea to make some of my own.

-Update- Seems I was missing some of the modules themselves.