Why won't the game launch?

I have recently bought this game on Steam and I have spent the past 2 hours attempting to get it to work.

The preparing to launch box pops up for a second or two and then disappears and is replaced by a box that says Democracy3.exe has stopped working (I have tried many times and this keeps happening).

Any reason why?

I have the exact same issue, the only difference is that on the very first launch after the install, it launched and got the the startup screen before crashing and saying Democracy3.exe has stopped working. Unfortunately now it does exactly the same thing as with TerraNatura’s symptoms of the problem.

I have the same problem as you guys. It was working fine yesterday but today it’s not working anymore, i reinstalled it, cleaned my registry folder, restarted my pc, it’s still not working.
I hope we can have an ETA on that soon™.

Happy new year tho,

Maybe this failure could have two causes:

  1. An old version of ‘Democracy 3’. Please make sure, you have installed the latest version of the game.
    Changelist Thread: viewtopic.php?f=36&t=8312

Maybe the automatic update process in steam for your game is disabled here.

  1. Some activated mods/modifications are not compatible. Deactivate all mods for your game and make sure, that you don’t subscribe any mods from the steam-workshop for your first start, to check, if this problem could be solved with this method.

In your personal folder on the hard-drive C:\ (e.g. C:\User\Name\Documents\MyGames\democracy 3), you will find a folder, called ‘debug’, which can help you to detect the problem.
This folder includes a debug.txt, a drawdebug.txt and an errors.txt.
Also a windows-search for these files could help, too, to find these files easier.

If the problem still exists, please copy the files into this thread here. :wink:


Thank for replying.

Nontheless I don’t have a “error.txt”, debug and drawdebug only.
I read them both and didn’t find anything wrong about it. ;