Windowed Mode Graphics issues


#1

Hi,

Just bought the game and am enjoying it, but I’d like to be able to play it in windowed mode. When I attempt to do so, the screen refreshing doesn’t seem to work correctly. So I can still see dialogs that I’ve already closed. If I switch to full screen and back, the redreaw clears up the screen, but the effect continues once I convert back to windowed mode.

Additionally, I have rarely encountered a pop-up error message titled: “D3DEngine Error”, with the following message: “Please check for support at positech.co.uk Details=[Flip]”. This message seems to occur when swtiching back to the program running in windowed mode --but only rarely.

Anyway I’m running winXP on a Dell Laptop with a gig of RAM and an Intel 82852/82855 GM/GME Graphics Controller. I also have two monitors --hence the desire to use windowed mode.

Thanks.


#2

the dreaded intel video card drivers are my nemesis I’m afraid. And not just me, we hated these things when I was at Lionhead too. Sorry to say it, but intel just can’t make decent video card drivers, and there may be no easy solution. I’d make sure you have the latest ones anyway, but I wouldn’t be suprised if they are just buggy with regards to our engine.
If you dont mind sacrificing some visual bells and whistles, you can toggle the option of ‘advanced backdrops’ off in the options menu. It should redraw ok then (although it will look bland).


#3

I’m having more driver confusion than I suspected was probable. I downloaded the latest Intel drivers only to find that they won’t install because of some Third Party issue, so I grabbed the latest driver from Dell and when I went to install them I was informed that my current driver was more recent than that which I’d just downloaded.

Disabling the advanced backgrounds doesn’t help me either.

I’ve also found that when I exit the game in windowed mode and then restart it, there’s some weird caching happening as I can see the screen artifacts from when I exited, with some bonus crud in the top black bar.

I can also reliably get the Flip dialog error. If I start the program in windowed mode, minimise it and then maximise it the dialog error occurs. But only once. To make it reappear I need to reload the application.

Planetary Defense works fine in windowed mode, and if I load Kudos after exiting from Planetary Defense, then the background is from Planetary Defense.

I can send you screen shots if what I’m saying is unclear, I had a brief look at drawdebug.txt and the only thing that seemed relevant was that, due to the detection of an Intel video card, 16-bit mode was being forced as was ‘Fallback Init’, which was successful.

Anyway, I’m not particularly worried about the issue, Intel is crap and Dell is crap by association. I’m sorry that you have to code in support for shite hardware.

Thanks.


#4

I know exactly the effect you describe. it MIGHT be the case that if you set your windows desktop to be 16 bit, then the problem will be solved (if its not already 16 bit). Basically the card is lying horribly about its ability to work in various video modes.


#5

Thanks, setting the desktop to 16-bit colour solved the problem.


#6

Good tip!

I would like to report that on my girlfriend machine, who is running on an ancient pentium with a Geforce MX 4, switching the desktop from 32 to 16 bit actually fixed the graphical glitches she was having… in fullscreen mode (alpha testing/blending didn’t seem to work, most buttons where bland gray squares, the dirty-house marks were huge red squares, black square around mouse cursor, etc). Also, the random crashes on ‘next turn’ seem to have disappeared now, but as she has only been playing for 8 mins since it’s too early to be sure.

Her NVidia drivers are pretty recent, and as opposed to those dreaded intel cards the old Geforce card is actually not half bad… :smiley: