Windows 7


#1

I bought this yesterday, as a part of the Positech winter bundle. I can’t get it to work, though, and I suspect it’s because I’m using Windows 7. I keep getting a error message saying something about DrawIndexedPrimitiveVB.

Is there any way to get this game to work in Windows 7, or should I just give up?


#2

Hello,

I have the same problem, I’m running Windows 7 with DirectX 11.

Every so often the game keeps getting interrupted by a DirectX error, but it doesn’t crash. The game continues when the message is dismissed, but halts again when the same error message comes up. This happens once or twice every minute.

I would like a solution to this problem, or a link to a more stable build. Do any of those exist? I’m someone glad that I’m not the only one with this problem.

P.S. I found that the problem is worse in Windowed mode (happens once every 5-10 seconds) and much, much worse in Windows98 or 2000 modes (happens non-stop - completely unplayable)


#3

I just downloaded the demo, to try out the game.
And I am having the exactly same problem.


#4

Hey, having the same problem here. windows 7, drawindexedprimitiveVb error, compatiability mode does nothing. The game minimizes until i click the error, and then pops back up for a minute or two. then errors again.


#5

Same error here.When it occurs, the game’s ui vanishes, and the gam itself lags like crazy.
Setting the compatability settings to Win2000 or 98 (forget which) seems to “buy” time until the error occurs.


#6

Bump for this. Is there a way to get Starship Tycoon to run on Windows 7? Cliff, thank you in advance for your response to my question.

Regards,

Bill D-G
Toronto ON


#7

I simply installed it and it runs fine… Windows 7 Ultimate. Have you done ALL of your microsoft updates? Are your video drivers up to date? Are your sound drivers up to date? Is your DirectX up to date?

I would suggest checking all those and running a MANUAL Windows Update to update your Windows.


#8

the “VB” at the end suggests Visual Basic. Make sure you have the latest Visual Basic runtime from microsoft.


#9

Hello!! I am having a Windows 7 related issue with the game, maybe.
The mouse is really sluggish, like there’s some gummy substance stuck to the bottom. There isn’t, of course :stuck_out_tongue: and the game is still playable but it’s really difficult to click on things. Does this have anything to do with running the game at 1024x768 on a screen that supports 1360 x 768? Maybe the game doesn’t know how to speed up the mouse properly with those measurements?

  • Mike

#10

I may have a workaround. You can play it in a virtual machine. You can setup Windows XP on it.
Few providers for it. Google for it.
Vmware, Virtualbox