iPad App Crashes

Whenever I load up a game or start a new game, when ever I try to open up a policy it crashes.

I’m on an iPad 4, running iOS 7. Please help me.

By the way this issue started when I downloaded the latest update; I’m running version 1.14.2

Mine is crashing also.

I have reset my ipad
Closed all other apps
Re-installed democracy

And nothing helps. I can’t make it past the tutorial. When I double tap middle class the app crashes.

Ipad with ios 7

Hi there, which version of the game is this? (top right of main menu).



I am having the same problem. I just downloaded the game today, and it keeps on crashing when I double tap.

I am running IOS 7.1.2 and game version 1.14.2.

I performed all of the normal troubleshooting steps (i.e. closing all other apps, uninstall and reinstall, and turning the iPad off and on again) and nothing helped.

Thanks for your help!

Version 1.14.2. I’m having the same issue. I went through all the steps above.

My iOS copy’s also crashing whenever I try to introduce a new policy. My version is 1.14.2.


Mine is doing the same :frowning: when I open a new game and go to set a new policy it just crashes.

I am running iPad 4 (retina display) with iOS 7.1.2.

The version of Democracy 3 I am running is 1.14.2

It’s 1.14.2

Me too. Same version, same problems. Please do anything, positech!

I’m afraid that this is a me too post.
Using a mini IPad everything was fine until the last update.
Now it crashes out everytime I to want to modify something.

I’d be happy if we just went back to the previous version :slight_smile:

I registered for this forum because of this problem with one of the neatest games for iPad. I had been having some crashing problems with the previous release, usually after an hour two of gameplay. Now it crashes after one turn. Rolling back the latest release would be better than what we have now, although I’d be pleased if it didn’t crash at all.

I have also been having the same issue

I’m also experiencing crashes so frequent I can’t even get past the tutorial. I just purchased the game for my iPad Air earlier this afternoon, opened the app a little while ago, and got crash after crash in different places during the tutorial. After messing around a bit, the farthest I can get is the part where the tutorial tells you to double press the voting groups in the middle of the screen. Every time I double press a group the game crashes, no matter which group I select. It happens even with the tutorial off. Tried it with many different settings and nations, no matter what selecting the voting group forces me to the home screen.

Since I can’t get through the tutorial I’m not sure how important the information that part of the game provides, but this is unacceptable. Working in IT, I am usually very understanding with bugs and problems in games and the very demanding jobs that developers have. However, not even being able to move through the part of the game that tells you how this complex game operates in beyond frustrating.

I tried restarting the iPad, resetting it and reinstalling the game. If there are other things you would like me to test or if there is more information I can provide for you, I would be happy to do so.

Developers, please give us some insight into what’s being done, or when we can expect a fix.

Thank you

Please can any dev’s advise if this issue is being looked into?

Ditto to all of the above. Just bought game today… (Didn’t look at reviews…) but very excited to play this game. Please fix this game!

While I’m not a Dev and don’t know, I can bet you that Cliffski is already attempting to speak to the iPad Dev(s). Or the iPad Dev(s) are already working on a fix to the issue.

If anyone is reading this, check their Updates in the App Store, as I’m just downloading the fix for the crash right now!

It seems to be working for me as well, now. Thank you!

Thankyou for introducing the fix… Just in time for my business trip! This is a good game to pass the time whilst flying.

Just a thought though, would have been encouraging if dev’s could mention that they were working on a fix rather than us being left in the dark.