[bug 1.05] deployment screen non-functional


#1

after running a challenge, then escape-quitting back to deployment, nothing was clickable. one ship was selected, but couldn’t be moved. no other ships selectable, buttons made a noise but did nothing. escape went back to scenario-select and things worked then.

naturally, when i tried to rapidly repeat this, it didn’t occur again. typical


#2

It happens to me almost every time when I press escape, select “Yes”, then immediately select “Deployment” in the statistics and then place a new ship. Then the whole menu goes bonkers and I have to press escape to go back to the main menu.

Edit - when I go into the designer from deployment menu, edit a ship, save it and then come back the same bug happens.


#3

I can’t replicate this, what am I missing?

I start the game
Go to challenges
click ‘fight’ on a challenge
Add some ships, and save them (or not) as a deployment
click fight and start the battle
hit escape and select yes
select deployment…
All seems usable every time I try it. Am I missing a step?


#4

Yes - it seems to happen only in Single Player :smiley:


#5

Some of us were talking about this (or something very similar) in 1.04 when running it in WINE on a Linux machine and the behavior is nearly the same as folks are starting to see in Windows. (i.e. buttons make sound but don’t function on deployment screen) I run the game in Windows most of the time and haven’t had it happen yet on my Windows partition. I am now running 1.05. The difference in WINE is it will start to happen during deployment, so sometimes you don’t get your map set before things go “non-clickable”. Our work-around was to save your deployment often until you got it the way you wanted. I am not WINE-ing about it not working on Linux, but I thought the behavior may lead to an idea of the problem on the Windows machines.


#6

My first time into the game after patching to 1.0.6 I went straight to my challenges, picked one on a large map, clicked the fighters icon and deployed one wing of fighters. After that I couldn’t deploy anything else, or trigger the fight, or save/load deployment. I could go into ship design and out again, and eventually I went back to the main menu and everything was fine from then on.

I can’t reproduce it either though.