Cant install 1.05 (setup files corrupted)

Every time I try to run the 1.05 installer I get the error
“The setup files are corrupted. Please obtain a new copy of the program”


i got the same error

Hi there! I got the same error.
I’ve been looking at this youtube video for help, it seems good but didn’t solve my problem, it might help you though.

same, and its really annoying

yep anyone managed to download from torret?

Same error here. I downloaded the file directly from the website. The torrent link has been Stalled as it has no seeders

Same problem here. Too bad i deinstalled the previous version and it’s setup. I’m unable to play now.

you probably still have the installer for the last version in your downloads

Same here.

I’ve got 83% of a torrent. :-/

Also having the setup corrupted issue. The torrent also got stuck at 83% for me but the direct download goes to 100% (not that it matters :joy:).

yep, id happily seed it if i could download the whole thing

I’ve done a bit of experimenting - and the torrent file itself is somehow corrupted (I’ve never seen this before). It’ll be a problem on Humble’s end as this isn’t managed by the developers. I’ve tested it by trying to seed with the (identical but differently named) direct download link, which gives me 84.7% download completion - same as you are all getting.

It’ll be worth us all sending Humble an email to discuss the 84.7% problem, as they must have a bug somewhere in their system :slight_smile:

1 Like

Glad I’m not the only one with this issue.

Hey all, dev uploaded a new file – try now, it’s working for me!

Not sure if the torrent is working, I direct downloaded.

1 Like

Problem solved here, thanks

yayyyyyyyyyyyyyy its working