Democracy 3 crashes when I try to load it

I just got Democracy 3 from steam and it will not load the game. Whenever i try to load it, a black box appears and they game crashes. I checked the debug files and it said that it failed to load the stats.ini and tut_seen.ini files. I already tried deleting all the mods, uninstalling it and re installing it several times, and deleting the files and re downloading them. I am currently running Windows 7.

any ideas would be appreciated since i can’t play until this is fixed

Hi, those ‘errors’ are perfectly fine, those files shouldnr exist on first run.
Can you post more information about your setup, and post the debug logs here.

The debug file:
[14:16:14:620]- ----DEBUG FILE----
[14:16:14:620]- Windows 7 detected
[14:16:14:620]- Command Line: “C:\Program Files (x86)\Steam\steamapps\common\Democracy 3\Democracy3.exe” windowed
[14:16:14:620]- Command Line argument:[windowed]
[14:16:14:621]- Desktop resolution is 1440 x 900
[14:16:14:623]- Initialising Sound Engine
[14:16:14:745]- Attempting to initialise steam
[14:16:14:934]- Steam initialisation success
[14:16:14:935]- Requesting steam stats…
[14:16:14:935]- …Steam stats requested
[14:16:14:935]- Initialising Direct3D
[14:16:15:93]- Initialising global vertex buffer
[14:16:15:109]- GBufferedFile failed to open file [C:\Users\Family\Documents/My Games/democracy3/stats.ini]
[14:16:15:109]- GBufferedFile failed to open file [C:\Users\Family\Documents/My Games/democracy3/stats.ini]
[14:16:15:129]- GBufferedFile failed to open file [C:\Users\Family\Documents/My Games/democracy3/tut_seen.ini

Anyone knowing anything that could fix this please post your suggestion since i cant play the game until this is fixed

I have the exact same issue. The debug says the same. But the files are not there for me. I did mod the game at first time running which might have been a mistake. I think that the game for some reason thinks it is not the first time running. Iv tried re-installation but that is no god. Iv poked at the pref file, but still. Deleting the folders still does not work.