Error on Startup


#1

I downloaded the demo to see if this game would work on my Windows 7 box before I bought it. When I start the game I can hardly move my mouse, and none of the boxes render. All I see is the background and the text “Quit Game” (not that I can get to it, I either have to press Esc or if that doesnt work, which it often doesnt, I kill the process).

Here is debug.txt:

----DEBUG FILE---- Windows Vista detected releasing resources writing global vars releasing game subystems releasing d3d Clearing textured sprites END DEBUG---

And drawdebug.txt:

Initialising Direct Draw Attempting fullscreen mode Creating Context at 1024 768 32 Forcing Fallback Init Attempting Fallback Init Fallback init succeeded Driver: NVIDIA GeForce 8600M GT \ Microsoft Direct3D Hardware Transform and Lighting acceleration capable device VidMem: 1013 MB Texture created : data/bitmaps\fonts\tahoma12.dds tahoma12.dds Texture created : data/bitmaps\fonts\verdana12.dds verdana12.dds Texture created : data/bitmaps\fonts\verdanabold16.dds verdanabold16.dds Texture created : data/bitmaps\fonts\arial16.dds arial16.dds Texture created : data/bitmaps\fonts\arialbold16.dds arialbold16.dds Texture created : data/bitmaps\fonts\arialbold20.dds arialbold20.dds Texture created : data/bitmaps\fonts\tahoma30.dds tahoma30.dds Texture created : data/bitmaps\title.bmp title.bmp Texture created : data/bitmaps\button.dds button.dds Texture created : data/bitmaps\button_h.dds button_h.dds Texture created : data/bitmaps\spark_red.dds spark_red.dds Texture created : data/bitmaps\spark2.dds spark2.dds Texture created : data/bitmaps\spark.dds spark.dds loadscreen.jpg Texture created : data/bitmaps\cursor.dds cursor.dds upsell.jpg Release D3DEngine Redundant calls/frame = 0.000000 Engine already released

I have tried it on all compatibility modes, and without.


#2

I have this issue too. On the full version.


#3

Me three. PLEASE HELP, I WANT THIS GAME.


#4

I have the same problem, just bought it and can´t play. please help
i even tried in windowed mode but sam again…
debug.txt:

----DEBUG FILE---- Windows Vista detected Vertex buffer lock failed Clearing textured sprites

Initialising Direct Draw Attempting windowed mode Creating Context at 1024 768 32 context created Device obtained backbuffer obtained Driver: NVIDIA GeForce GTX 275 \ Microsoft Direct3D Hardware Transform and Lighting acceleration capable device VidMem: 2286 MB Texture created : data/bitmaps\fonts\tahoma12.dds tahoma12.dds Texture created : data/bitmaps\fonts\verdana12.dds verdana12.dds Texture created : data/bitmaps\fonts\verdanabold16.dds verdanabold16.dds Texture created : data/bitmaps\fonts\arial16.dds arial16.dds Texture created : data/bitmaps\fonts\arialbold16.dds arialbold16.dds Texture created : data/bitmaps\fonts\arialbold20.dds arialbold20.dds Texture created : data/bitmaps\fonts\tahoma30.dds tahoma30.dds Texture created : data/bitmaps\title.bmp title.bmp Texture created : data/bitmaps\button.dds button.dds Texture created : data/bitmaps\button_h.dds button_h.dds Texture created : data/bitmaps\spark_red.dds spark_red.dds Texture created : data/bitmaps\spark2.dds spark2.dds Texture created : data/bitmaps\spark.dds spark.dds loadscreen.jpg Error locking VB DDERR_GENERIC Problem creating Vertex Buffer DDERR_GENERIC Texture created : data/bitmaps\fonts\tahoma12.dds tahoma12.dds Texture created : data/bitmaps\fonts\verdana12.dds verdana12.dds Texture created : data/bitmaps\fonts\verdanabold16.dds verdanabold16.dds Texture created : data/bitmaps\fonts\arial16.dds arial16.dds Texture created : data/bitmaps\fonts\arialbold16.dds arialbold16.dds Texture created : data/bitmaps\fonts\arialbold20.dds arialbold20.dds Texture created : data/bitmaps\fonts\tahoma30.dds tahoma30.dds Texture created : data/bitmaps\title.bmp title.bmp Texture created : data/bitmaps\button.dds button.dds Texture created : data/bitmaps\button_h.dds button_h.dds Texture created : data/bitmaps\spark_red.dds spark_red.dds Texture created : data/bitmaps\spark2.dds spark2.dds Texture created : data/bitmaps\spark.dds spark.dds loadscreen.jpg


#5

Hi, have you got the latest drivers for your video card?
Have you tried checking the icons compatibility mode and running in compatibility mode for an earlier version of windows?
It’s likely this is a bug relating to video cards and running directx, which is the version Democracy 2 uses.


#6

It seems that the problem really is the video card. I own a GeForce 8800 GT, and it doesn’t work. A friend of mine came over, we tried with his video card instead (A Radeon HD 4750)… And it worked. Flawlessly.
My drivers are all updated. Good thing I plan on buying a new GPU anyway.