Finally got the source code for this...


#1

For a while the source code to starship tycoon was on a dead hard drive, but I finally recovered the data this weekend and started trying to get it to build properly so I can get fixes done etc.
I’m trying to fit that around other stuff, and the code is very old, so it will take a whle, but I thought i’d announce some rare news regarding this game :smiley:


#2

That is AWESOME, Cliffski! 8)

Are you planning any possible ability to allow modding of it more than just re-writing the code to create another mission? :open_mouth:

Either way, still the best news I’ve heard in a long time!! :mrgreen:


#3

No idea yet, I need to get the damn thing to work right with my new text engine and all the rest of its quirks yet.


#4

I’ve got a game where a crewman is not in the crew list, not on leave, but shows up in the cabin,
I ended up selling and re-buying the cabin to get rid of him (he was a pilot) but he keeps begging for a pay rise.

also, I can’t pause the game when I have notifications from the crew, which is a pain when you’ve got the game speed set to fast.

I think I may have somehow left the pilot on annother planet on that game…
I gave up on it, but I do have the savegame for it. don’t know how I managed to leave a planet without a pilot, and in any case, his picture should not have shown up in the CQ.

ran into another problem too, a crashy one, tried a bunch of things, rebooting, making sure everything was shut down etc, and tried changing crew, and cargo, heading etc, but after a given amount of time, the game crashes.
here’s the last few lines of the debug code. I’ve keeped a savegame of this one too.

t: 16096978.000000 H:1128 - MESSAGE: Recruitment Report: There are engineers looking for work on CALLORL 
t: 16096979.000000 H:1128 -  
t: 16107786.000000 H:1143 - Deactivate app message 
t: 16115109.000000 H:1143 - Assertion failure:filename:C:\data\programming\StarLinesShareware\AIAgent.cpp,linenum:586,build:BUILD 2.41,datafile:.\data\maps\THE TERRAFORMING DEAL.scn,Windows XP detected 
t: 16115117.000000 H:1143 - Vertex buffer lock failed 
t: 16115117.000000 H:1143 - Releasing Resources 
END DEBUG---

I was close to wining that one too! fortunately I had an earlier savegame that I was able to go back to.


#5

Damn. i suspect this is a symptom of some really evil bug that’s corrupting data somewhere. They are a nightmare to track down, especially with really old source code.


#6

if you do make a patch, can you do something about how when “autopause on when dock” is check, that the range gets updated? as it is currently, you have to play a second before the range gets updated.


#7

Hey, Cliffski!

I was just wondering if anything was still going on with ST1? Or will there be an ST2?