Missing d3dx9_42.dll after latest patch


#1

Just installed the latest patch, and all of a sudden on launch I am getting a missing d3dx9_42.dll error. The game worked perfectly before… Any ideas?

I’m running Win7 x64.


#2

Gah. I hate the world!
I shall investigate immediately.


#3

I concur, I have the same issue after updating. It says “Please try reinstalling the game”, etc.


#4

expect a patch 1.35 VERY quickly :smiley:

anyone who has this borked version may need to totally reinstall though :frowning:


#5

yeah i have the same issue here just so you know - i updated 5 minutes ago… :frowning: - but gah i dont want to have to re-install - what would be the process? just un-install and install or do you want me to download the new version after you patch it to 1.35…


#6

I’m redownloading the game just in case that is so.


#7

Don’t take this the wrong way but could you be a bit more careful with your (at least critical) bug crushing? This is the third for me time a patch has made the game unrunnable requiring reinstallation. If this is a problem not in your control I apologise in advance.


#8

It’s not actually a bug in the code at all, but in directx’s installer. Good old visual studio automatically compiles code so that it uses the very latest directx files, regardless of whether you use its features. I’ve moved my development to a enw windows 7 64 bit PC, and instaleld the latest SDK, which is the only one Microsoft let you downlaod easily anyway.
The reason this wasn;'t flagegd up in my tests (I test on several PC’s) is that they all have those files anyway, and it is officially impossible according to microsoft to unisntall directx in any way :frowning:
Trust me, I don’t want this to happen any more than anyone who buys the game!

Version 1.35 is now out and should work ok. the problem is, if your version cannot start, it cannot autopatch, but email me if you would rather have a different solution to reinstalling the whole game (it’s a 55MB download from your original install link, it is now 1.35).


#9

I see, well I guess that isn’t your fault. Will reinstall from link.

And keep up the good work =)


#10

Thanks for the fast turn around Cliffski. Always appreciated!


#11

i had the same problem this is how i fixed it download install/uninstall demo then then install nondemo version and it worked


#12

Hello silv,

http://www.d3dx9.net/download-missing-d3dx9_42-dll/
You can get the d3dx9_42.dll file from the above link.
this is the source which is best for solving this sort of dll related issues.
Click the Link on this page “Run a Free DLL Scan” and it will fix it for you.