[SUPPORT][LINUX]Graphical Issues using Open Source Drivers


#1

Recently I bought Big Pharma and ran into issues running it on Linux Mint. Using the default Open Source Drivers for my system causes the game to not render graphics properly and makes navigating the menus difficult as clicking on the buttons does not always work. I was able to play through the first tutorial, but the graphics were not working.

To fix the graphical problem I upgraded to the proprietary drivers on my system, which first lead to the game not loading past the developer logos with the Steam Overlay enabled. Disabling the Steam Overlay allowed the game to load but it then would crash if you entered the ingredients tab(likely other tabs as well but I did not test further). Graphically the game worked and the menu buttons were no longer an issue, but crashing makes the game unplayable.

I have tested this on both the Steam Version, and the DRM Free Standalone. I believe the second issue is related to Unity3D not working properly with the proprietary drivers(unable to play Table Top Simulator either and saw it had logs in the Unity3D folder just like Big Pharma).

Comparison Album: http://imgur.com/a/UFn5U
Note: I had to boot up a live usb to take the open source Ati screenshots as I was unable to switch to them on my laptop.

Other System Details:

00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Trinity [Radeon HD 7640G] [1002:9903] (prog-if 00 [VGA controller])
	Subsystem: Acer Incorporated [ALI] Device [1025:0696]
	Flags: bus master, fast devsel, latency 0, IRQ 49
	Memory at e0000000 (32-bit, prefetchable) [size=256M]
	I/O ports at 4000 [size=256]
	Memory at f0400000 (32-bit, non-prefetchable) [size=256K]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: <access denied>
	Kernel driver in use: fglrx_pci

OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: AMD Radeon HD 7640G
OpenGL core profile version string: 4.3.13374 Core Profile Context 15.20.1013
OpenGL core profile shading language version string: 4.40
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.4.13374 Compatibility Profile Context 15.20.1013
OpenGL shading language version string: 4.40
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile
OpenGL extensions:

Machine:   System: Acer product: Aspire V3-551 version: V2.13
           Mobo: Acer model: VA50_CM Bios: Insyde version: V2.13 date: 05/09/2013

#2

Which version of Mint and which kernel-version?

The problem with the propritary drivers are known viewtopic.php?f=50&t=14334 and i think Twice Circled is waiting for an answere from the Unity3D developers.

On my computer the opensource-driver work very well, but iam using a recent kernel (4.x).


#3

From running uname -a:

Linux RMDan-JunkLinux 3.16.0-38-generic #52~14.04.1-Ubuntu SMP Fri May 8 09:43:57 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Would updating the kernel help? While I am familiar enough with Linux Mint for a lot of things, I haven’t done much under the hood so I would need some instructions on how.


#4

Unlikely. The driver is splited up into two parts, one in the kernel, and one in the user-space.
Updating the kernel only may help, but i think is unlikely if the other part does not get an update.

The easiest way would be to install the newest mint-version if youre not already use them, in my opinion.


#5

Thank you for your informative post. As roidal says, this is a known issue, but unfortunately I am no closer to solving it at the moment. I will add a reply to this other post: viewtopic.php?f=50&t=14334.

I’m so sorry for your inconvenience. I am continuing to try to get the issue solved but as you have no doubt deduced, it seems to be quite a low-level issue in Unity and could even be unsolvable. If you would like to cut your losses and get a refund, I’d be happy to facilitate this process with my apologies. Just email support@twicecircled.com.