Very interesting game, but I can't use mouse cursor


#1

I’m using a PC, with a mouse. After starting the game I don’t have much control because I don’t see the mouse cursor. The center controls will occasionally light up as I use my mouse to try to select one. But it seems to be hit or mostly miss. The arrow keys, tab key, page up and page down don’t affect anything. What do I need to do to navigate?
Thanks for any help.
Nils


#2

that’s weird… I can normally use the mouse. Are you using fullscreen or window mode?


#3

I use full screen. It is difficult for me to navigate without seen the mouse cursor. I can go to Options, and I’ve tried changing the resolution. The resolution changes, but still no mouse cursor. I cannot switch off the full screen option, because of limited navigation ability.

I have tried all the compatibility options with Windows. Although I am running Win 7 64 bit on a laptop only 1 year old (Dell Precision), I tried compatibility options Win XP SP2, Vista, Vista with SP1, Vista with SP2. I tried running as Administrator. None of these options will show me a cursor when in the program. I’ve tried different mouse cursors.

All the drivers on my PC are up to date. This is a very unusual problem, first time I have seen it in many years of PC work.

A simple description of the problem: after Democracy 3 starts, mouse cursor disappears. Objects on the screen do light up as I move the mouse and presumably the cursor has contacted an object. However the screen never shows where the mouse cursor is, until I exit the Democracy 3 program.

I’ll see what is involved in submitting a trouble ticket to the publisher. It looks like a great game, I’d like to try it!

Nils


#4

I looked around the website and found info about two debug files being written by Democracy 3.

This is the debug.txt file which indicates some problems I believe, starting with “Steam initialisation failed”.
Hopefully these are clues for someone, to explain why my mouse cursor does not ever appear on the screen.

[20:12:22:91]- ----DEBUG FILE----
[20:12:22:91]- Unknown O/S build number : 4
[20:12:22:91]- Command Line: C:\PROGRA~2\DEMOCR~1\DEMOCR~1.EXE
[20:12:22:91]- Desktop resolution is 1920 x 1080
[20:12:22:101]- Initialising Sound Engine
[20:12:22:101]- Writing default options
[20:12:22:121]- Finished Initialising Sound Engine
[20:12:22:121]- Attempting to initialise steam
[20:12:22:121]- Steam initialisation failed
[20:12:22:121]- Initialising Direct3D
[20:12:22:221]- Initialising global vertex buffer
[20:12:22:231]- GBufferedFile failed to open file [userdir/democracy3/stats.ini]
[20:12:22:231]- GBufferedFile failed to open file [userdir/democracy3/stats.ini]
[20:12:22:251]- GBufferedFile failed to open file [userdir/democracy3/tut_seen.ini]
[20:12:27:331]- GBufferedFile failed to open file [userdir/democracy3/lst_chk.ini]
[20:12:27:331]- Start of SIM_Internet::OpenLink
[20:12:27:341]- End of SIM_Internet::OpenLink
[20:12:27:341]- democracy3/server/check_update.php?&current_version=1.140000&platform=windows&lang=english
[20:12:27:341]- SIM_Internet::DownloadFile(userdir/democracy3/webdebug/tmp785.html)
[20:12:30:881]- SIM_Internet::DownloadFile ends
[20:12:30:881]- message,up-to-date

[20:12:30:881]- response,false

[20:12:30:881]- response,false

[20:12:30:881]- Start of SIM_Internet::CloseLink
[20:12:30:881]- End of SIM_Internet::CloseLink
[20:12:39:441]- releasing D3D engine
[20:12:39:441]- D3D released
[20:12:39:441]- Start of SIM_Internet::CloseLink
[20:12:39:441]- IERROR: Internet: InternetCloseHandle() Failed [6]
[20:12:39:441]- IERROR: Internet: InternetCloseHandle() Failed [6]
[20:12:39:441]- End of SIM_Internet::CloseLink
[20:12:39:441]- releasing D3D engine
[20:12:39:441]- D3D released


#5

I discovered a work-around to the problem of why the mouse cursor did not appear - I am using Windows 7 64-bit. On three different Dell Precision laptops, with Win 7 64-bit, I could not see the mouse cursor. When I tried Democracy 3 on a Windows Vista 32-bit, the problem went away. Finally!
Nils G