[1.17] Crash when entering challenges menu


#1

This is what I have in my errors.txt

15/10/2009 - 0::26 - Assertion failure:filename:…\src\GUI_DeploymentGUI.cpp,linenum:193,build:Beta 1.17


#2

I’m investigating this now, should be a simple fix.


#3

Unhandled exception at 0x7c812afb in GSB.exe: Microsoft C++ exception: std::out_of_range at memory location 0x0012f4b8…

In case this helps…


#4

I’m having a similar crash. The full message reads as follows:

Runtime Error

Program: C:\Program Files\Gratuitous space battles beta\GBS.exe

The application has requested the Runtime to terminate in an unusual way.


#5

I also get this.


#6

I fixed this earlier. If you re-run the 1.17 patch, it should be gone. Unless I’m mistaken and I failed to fix it properly?


#7

I first downloaded the patch from the in-game auto downloader when it was officially released, got the error. Tried to download the .exe version from the thread in GSB general discussion but it also gives me the error.


#8

No it doesn’t help. Entering challenges crashes the game. No records n errors.txt


#9

I just downloaded the new patch and i get this as well, generic windows crash error whenever i click the challenges button.


#10

me too! >:(


#11

Yes, me too. Worked fine for me previously, but after installing 1.17 I get a “runtime error” and crash to desktop when I click the “challenges” main menu button. The crash added nothing to any of the three debug text files.


#12

Reran the patch, still crashes.


#13

Ok, here’s how I fixed it. I removed the “My Documents/My Games/Gratuitous Space Battles/Web” folder (and stored it elsewhere because I’m paranoid like that but you can just delete it if you like). Now you have to reenter your online serial number / game code with the online button. Then challenges will work again. The problem is apparently an old file that is now not compatible with the latest version of the game. Dunno which one it was. Oh well, I can play again and I wanted to post this info in case it helps anyone else! Good Hunting!


#14

I renamed just one file:
My Documents\My Games\GratuitousSpaceBattles\web\challenges\challengelist.txt

and all was well.

No need to reenter my serial.
No need to re-download challenges I’ve already got.

This appears to be the file that caches the list of challenges (rather obvious from the name :smiley: ), I guess the new version tried to read it as if it contained all the extra data we now see.

Cliffski: most obvious solution to my eye, would be for the 1.17 patch to simply remove this file when it installs, since a new one will get created the first time you go looking for challenges anyway.


#15

Yes this is the right fix, and the right reason for the crash. It hadn’t occurred to me that this would happen, and in many many tests I’ve obviously deleted that file and thus not encountered the problem :frowning:
Sorry about that.


#16

If this helps: the 1.17 patch also skewed the 2 deathmatch single player challenges. No ships appeared in the selection pane?

Update: The renaming of the challengelist file fixes the online challenges, but the 2 deathmatch challenges are still broken not listing any ships in the selection pane?

Update: fixed the deathmatches, had to go in and select race again.


#17

hmm, i tried to rename the file, but i couldn’t find it, even though i had data, debugdata, etc. in the folder on my mac desktop! it was there last time! could cliff plz fix it in 1.18? after all, he fixed the empire sound problem in 1.17.


#18

I’m sure it will get fixed, in the meantime, if you’re using Mac with Crossover / Wine, why not use spotlight to find the file? I’m not sure where “My Documents/My Games” ends up when you use X-over or Wine. On Windows proper it’s pretty obvious.


#19

On a Mac using CrossOver, you need to look the in the My Games folder in your Documents folder.

In the Finder, if you hit [shift]-[command]-[f] and copy ~/Documents/My Games/GratuitousSpaceBattles/web/ into the text entry box and hit return, the correct folder will open.


#20

i didn’t actually go to my documents first, got it mixed up with data, but now it’s ok. Yay!