Beta 1.15 repeatable crash, game in unstartable state


#1

Easily fixed, fortunately, but a little user error will cause the game to crash trying to initialize the renderer, and will continue to do so when the game is started. This may require two monitors, if the multi-monitor option is not displayed on single monitor systems.

Steps to reproduce:

  1. Start game.
  2. Click Options.
  3. Select multi-monitor and note that the full screen and borderless options are removed. Apply changes.
  4. Click Options.
  5. Note that the full screen and borderless options are back.
  6. Select Full Screen, and Apply Changes.

Observed: The screen will go black, and not return. Upon clicking, the game will crash. Attempting to run the game again will crash it again. The following is written to errors.txt:

7/2/2015 - 1::37 - D3DERR_INVALIDCALL
7/2/2015 - 1::37 - CreateDevice
7/2/2015 - 1::37 - D3DERR_INVALIDCALL
7/2/2015 - 1::37 - CreateDevice failed again
7/2/2015 - 1::37 - Failed to initialise 3D Engine:…\src\Game.cpp 435
7/2/2015 - 1::42 - D3DERR_INVALIDCALL
7/2/2015 - 1::42 - CreateDevice
7/2/2015 - 1::42 - D3DERR_INVALIDCALL
7/2/2015 - 1::42 - CreateDevice failed again
7/2/2015 - 1::42 - Failed to initialise 3D Engine:…\src\Game.cpp 435
7/2/2015 - 1::49 - D3DERR_INVALIDCALL
7/2/2015 - 1::49 - CreateDevice
7/2/2015 - 1::49 - D3DERR_INVALIDCALL
7/2/2015 - 1::49 - CreateDevice failed again
7/2/2015 - 1::49 - Failed to initialise 3D Engine:…\src\Game.cpp 435
7/2/2015 - 1::56 - D3DERR_INVALIDCALL
7/2/2015 - 1::56 - CreateDevice
7/2/2015 - 1::56 - D3DERR_INVALIDCALL
7/2/2015 - 1::56 - CreateDevice failed again
7/2/2015 - 1::56 - Failed to initialise 3D Engine:…\src\Game.cpp 435

This can be corrected by deleting \Documents\My Games\GratuitousSpaceBattles2\prefs.ini, which will then allow the game to restart with defaults.

Edit: Suppose I ought to have included my hardware.
i7 2700K @ 3.50 Ghz
nVidia GTX 970
16 GB RAM
2x 3840x2160 displays (using the game at that resolution)


#2

Thanks, I’ll get this fixed. I think we have several screwups when we added the borderless option, it seems to get confused between that, full-screen & multi-monitor. Should be a relatively quick fix.


#3

I tried to turn on Fullscreen multi-monitor and ended up with a similar bit of wackiness. Sounds like you are on it, but wanted to let you know that it is not just when turning things on when in single monitor mode. I have three screens.