Crash when any main menu choice is selected


#1

Using my crappy laptop, the game crashes when you select any of the main menu options. It’s probably due to the crappy video card (an on-board 64 MB Intel 82852/82855…told you it was crappy!) as the errors.txt displays the following:

4/11/2009 - 13::45 - D3DERR_INVALIDCALL
4/11/2009 - 13::45 - CreateDevice
4/11/2009 - 13::45 - D3DERR_OUTOFVIDEOMEMORY
4/11/2009 - 13::45 - Error creating texture:[$s]
4/11/2009 - 13::45 - D3DERR_OUTOFVIDEOMEMORY
4/11/2009 - 13::45 - Error creating texture:[$s]
4/11/2009 - 13::45 - D3DERR_OUTOFVIDEOMEMORY
4/11/2009 - 13::45 - Error creating texture:[$s]
4/11/2009 - 13::45 - Assertion failure:filename:…\src\GUI_Transition.cpp,linenum:53,build:Full 1.23

Is there a way of toning down the graphics options outside of the game? I can’t even select the “options” menu without the game crashing.

This is a no-big-deal problem, as I can play the game on my manly desktop.


#2

I know exactly what this is. Its the wipe transitions, which are ‘on’ by default. They should automatcially toggle off if they ever fail, so running the game again should fix it. if that fails, you can manually force them off by editing this file:

MyDocuments\My Games\GratuitousSpaceBattles\config.txt

this line:

TRANSITIONS = 1.00

to this:

TRANSITIONS = 0

It should probably run ok then (without my lovely star-wars wipes)


#3

Ah, My Documents…darn you Windows.

Didn’t fix it though, even though I totally agree that that is what the problem is.


#4

In that case, you may need to stick with the manly desktop…


#5

Yay I managed to make the demo work. I’ve got the same error log.

I’m using a VAIO with a Centrino 1.6Ghz.
1GB of RAM.
Video Card is Intel 82852/82855 GM/GME with (supposedly) 64MB of Video Memory!

I made a mistake of running the game in Windows 98 Compatibility mode, and so the configuration files are created inside a “usrdir” in the game folder.
Tried to edit the config files in the My Documents folder and of course, there’s no effect.
Thought all hope was lost until I noticed the “usrdir” (which was not deleted when I did an uninstall).
Edited the config files in there and it finally worked.
(The edit was to make TRANSITIONS = 0.00)

Anyway, the game works without compatibility mode.
Just make sure you don’t get confused like I did.
So…

  1. If you made the compatibility mode on, (and forgot about it) GSB creates and uses the config files in the “usrdir” in the game folder.
  2. With compatibility mode off, GSB uses the config files in the My Documents/My Games/Gratuitous Space Battles Demo/ folder.
    You don’t really need compatiblity mode on. Just be aware in case you’ve been messing up with your settings.

And some of my in-game settings:

  1. Turn the Shaders OFF. Game crashes after deployment if the Shaders are ON. (I prayed hard for this one to work).
  2. 1024 x 768 Resolution.

Everything runs fine!, some slow down when things get crowded in the tutorial stage. Maybe need to turn off some effects.

The demo’s working in my laptop now! I can buy the game!


#6

Yay!
Win98 doesn’t have MyDocuments, so it uses that workaround…


#7

Did the stuff in the Win 98 compatibility mode post, now the game menus work but when I click Fight it crashes again. I’m on the Steam version (1.23) if that matters.


#8

have you tried turning the shaders off?


#9

After a redownload of the game, I turned it off and now it works! No lag, nothing on this laptop which is similar in spec to the other laptops described here. Thanks so much. Just finished the tutorial, and that already was a blast (hehe) to play. Well worth the $20.