[BUG] Mission select screen broken


#1

First, I alt-tabbed during a battle, and got a black screen with music when I returned. Now, when I go to the mission select screen, pressing the mouse on anything other than ‘deploy the fleet’ causes the screen to re-start (sliding on the battle list). Esc works to leave the screen, and pressing deploy works, but I can’t select any battle other than the first one, nor change race. This continues even after re-starting the game.


#2

I’m having the same issue- and searches for a solution turned up nothing. I tried uninstalling and reinstalling, which worked once. But than it went right back to doing the same thing. And a second uninstall + reinstall did not resolve the issue.


#3

I had on person with this, although I havent reproduced it yet. Apparently entering the online username and serial code fixed it. I will investigate further.


#4

I’ve just stuck this issue now too. I did the following to create it, I think…
I just completed the 10th scenario on Normal and when into scenario 11 - this created the scenario 11 folder for deployments.
I then exited the game and copied the scenario 10 deploy.txt to the scenario 11 folder.
Started the game again and went into Battle; now can not select any scenario after The Chaos Nebula. I can go into the Race screen. I can close Race screen. The Main Menu button does nothing but refresh the scenario listing.
The ESC key allows me to exit to base screen, and then exit game.


#5

I cannot reproduce this at all. Have any of you added (modded) in new missions? Is there a scroll bar on the list of missions? Which version of the game is this?

edit: I might have found it. I’ll include the fix in todays patch


#6

Further to my previous post, I have found that I can ‘unlock/unstick’ the Mission Selection mechanism by going into the Challenge Screen and loading your challenge (works with any challenge) and going through to the Deployment Screen. Exiting from there and going back to the Mission Selection screen, normal Mission selection is restored. I note however that the restoration only lasts for the current instance of GSB and returns to being stuck when GSB is restarted.

Hope this will help in tracking down this bug…


#7

Just saw your post and No, No, 1.07


#8

1.08 is now out, hopefully this fixes it.