How to play on a Mac


#1

I have made a short 4min video about how to install and play Big Pharma on a Mac and it seems to run great as far as I can tell so far for anyone interested.

Video Here:
https://youtu.be/BGcGQLeWiVA

Please like the video if it helped you :slight_smile:
Have fun playing.


#2

That’s incredible! Wow. Please post if you have any issues because I would hate to refer people to this if it had a downside.

Obviously this is no replacement for a proper mac version which will come eventually but it’s nice that anybody desperate to play, but no access to a PC, has this option. :smiley:


#3

If you would rather play the game in a window so that it doesn’t black other screens (if you have more than one) or you just like to multitask you can do that by following the steps below.

    1. Start the game in fullscreen mode as the video says.
    1. In the game options choose a resolution that is lower than your screens resolution (this will be the size of the window).
    1. Exit the game
    1. Right click on the app and choose the “Show Package Contents” option from the menu.
    1. Double click the Wineskin app to open it.
    1. Click “Set Screen Options”
    1. Choose “Rootless (Windowed)”
    1. Choose "Virtual Desktop at: "
    1. Make sure “Force Normal Windows” is selected
    1. Click “Done”
    1. Start the game again and it should start in a window.

#4

Neat - Just uhh… Remember to double-check any bugs you find on a Windows-based copy. Please make sure it isn’t WINE/Parallels that is causing them.


#5

Hi,
I followed the steps in the videos and the game launch.
However it created two files on my desktop “Big Pharma.lnk” and “Big Pharma.desktop”
Can I delete them ? Or at least, move them to the Wineskin folder where the Big Pharma.app is ?


#6

I’m running OS X 10.9.5 on a late 2012 Mac Mini and ran into some graphical difficulties with the settings given in the original video, probably based on the different video chipset and/or OS version. I did confirm that I’m using the same Wineskin Winery Engine version (WS9Wine1.7.44) and Wrapper (Wineskin-2.6.0) as in the video.

For me, to get the machines, factory floor, factory walls, etc. to display I had to use settings of:

WINE SCREEN OPTIONS:
Rootless (windowed)
Override
Normal Windows
Force Normal Windows
Decorate Windows (checked)
Auto Detect GPU Info for Direct3D (checked)

BIG PHARMA OPTIONS:
Full Screen
1920x1080 (real resolution, which gets changed to 1920x1058 automatically)

MAC OS DOCK:
Turn Hiding On (because the dock sits on top of the game screen)

If I out of the program and re-enter it will refresh the display and show the factory correctly with the machines. I also had to do this tab out to get the initial window with the initial upgrade button to show correctly. In the game, things like the ingredient and pill overlay for wall input/output nodes are still invisible but present (you can click on them if you know where they should be and watch for the cursor change), and the purchase button for factory tiles is also invisible (but also clickable when the cursor changes). The game is very playable despite the invisible overlays, needing to tab out and back to get the factory map to refresh, and needing to turn Hiding on for the Dock so it doesn’t sit on top of the game screen.

I cannot wait until it is released for real for OS X.


#7

The “Big Pharma.lnk” and “Big Pharma.desktop” files can safely be deleted.


#8

Yes you can delete those files.
You can also move the .app to wherever you would like it. I moved mine to the normal applications folder rather than the wineskin one.


#9

I’m running on a MacBook Pro, and the Mac driver for Wineskin seems to work better than other options:

  1. The game can go into windowed mode without crashing on startup
  2. Fullscreen mode hides the menu bar and dock automatically
  3. The cursor won’t disappear at random
  4. Wine shuts down faster

You can enable this by ticking “Use Mac Driver instead of X11” and leaving the rest on Automatic in the Screen Options.


#10

I was too optimist last time.
I can install Big Pharma and launch the game but when I try to do a level, I only have the floor of the first room.
No walls, no doors for the raw materials, no other rooms.

I am using a MacBook Air 13" early 2014 with OSX 10.10.3


#11

So after following the video directions I had problems with the factory floor and walls not rendering. After some fiddling with settings I found some that would at least let me play with some annoyances. Today, I sat down and dug into the problem and found a solution for my problem with the factory floor not rendering correctly, maybe it will help other people with the same problem.

Upon doing research, my problem was due to Direct3D not detecting my video memory correctly. I solved the problem by setting that value manually in the Wine registry. Now, when I use the settings given in the video I get the factory rendering perfectly with the machines, walls, floor, and information overlays all showing correctly.

  1. Figure out how much video memory you have (these instructions are based on OSX 10.9.5):
    a) Go to the Apple Logo in the upper left
    b) Select “About This Mac”
    c) Select “More Info…”
    d) The “Graphics” line lists my video card as “Intel HD Graphics 4000 1024 MB”, so I have 1024 MB of video memory

  2. Put that value into Wine:
    a) Browse in Finder to the location where you have “Big Pharma.app”, mine was under Applications->Wineskin
    b) Right click on “Big Pharma.app” and select “Show Package Contents”
    c) Double click on the “Wineskin.app” program
    d) In the top bar select “Tools”
    e) Select the button on the left labeled “Registry Editor (regedit)”

Here is where it got a little complicated. You want to go to the key “HKEY_CURRENT_USER -> Software -> Wine -> Direct3D” and change the value “VideoMemorySize” to match your video card (1024 in my case). On my system, the key for Direct3D was missing so I had to add it. Here is how you add the key and value:
a) In the tree view on the left browse down to “HKEY_CURRENT_USER -> Software -> Wine”
b) Right click on the “Wine” key and select New->Key, for the name of the new key use “Direct3D”
c) Right click on the new “Direct 3D” key and select New->String Value, for the name of the string value use “VideoMemorySize”

To change the value of VideoMemorySize you just right click it the right hand pane and select “Modify”. You are given an entry field where you can type in your video card memory value.

Hope this helps other people get Big Pharma rendering correctly on their Macs.

The TL;DR - Factory floor rendering problems were fixed by manually setting video memory size in Wine registry.


#12

Thank you Zleah_Shadow it finally works.
I still have to do CMD+TAB but I can play now


#13

Just wanted to mention that I had no problems auto downloading and installing the update to this today, even while using the program through a wineskin wrapper.