[Outdated][1.31] Crash while opening research

Just downloaded the new version to try the new features. Created a new factory, placed some slots and started production. After that I placed research-office slots, but when I wanted to assign research (opening research in the menu), the game crashes.
I tried to reproduce it, but it seems to work now. However I want to notify the developers.
I’ve attached the debug-logs.
drawdebug.txt (5.38 KB)
savegames.zip (63.9 KB)
debug.txt (1.65 KB)

Hmm. I haven’t heard of this anywhere else, was it maybe unrelated but just happening at the same time?

It seemed indeed that it was doing something. At least it took very long to load (the game was frozen), and after about 15 seconds the game stopped and got a Windows pop-up to detect the problem. However I was not able to reproduce it.

I have run into an issue with the game crashing, and I think what happened is I was trying to delete a bunch of stuff, a lot of clicking which needs to be changed, and I think when the game tried to do the Autosave is when it locked up and eventually gave an error. Ended up having to restart my pc.

I think the Demolish function should be changed that if you hold down the left mouse button and drag, it deletes everything the cursor touches. With touch, it might require a different approach. Problem is having to click each item to delete which is a royal pain when restructuring.

With regard to the OP:

I have had the crash when opening the Research Screen [<=1.30] though only ever at the start of the game.
(Beside the infrequent crash in this one situation the game have never crashed on me in well over 200 hours of play.)

This crash to desktop with no error message from the game or windows happened very infrequently.

With 1.30 and earlier I was starting and re-starting many games looking for optimal starts on each mission so I noticed this more but with such an infrequent crash and an eagerness to play while I did spend some time trying to replicate it, I didn’t grab the initial bug reports. Sorry about that. With the crash only ever happening at the start of the game and having my own ‘set start’ (M.O. below) I noticed the details when it did happen.

My usual ‘game start’ M.O.

  • Pause game
  • Place the initial Slots (Chassis Assemble, Fit Body, Fit Engine etc. )
  • Connect Slots with Conveyors
  • Place Resource Importers
  • Connect Resource Conveyors - Slot Stockpiles
  • Place (1-5) Research Office(s) (depending on mission)
  • Select Starting Research <-- CRASH POINT
  • Up % on Car design for initial Sedan
  • Full Speed Ahead !

I did make note of the following:

It only happened the first time I entered the Research Screen when starting a new mission, once I had entered the Research Screen and exited with or without selecting a research subject it did not happen again.

It happened when I place one or more Research Offices without first selecting any research subject and then enter the Research Screen.
(I was never able to force a crash by entering the Research Screen before placing a Research Office)

It happens when entering the Research Screen via the Slot or top menu bar.

[unconfirmed] it felt like once the game is up and running, i.e. quit a mission and start another without quitting the game entirely the crash did not happen.
[unconfirmed] if i forgot to pause the game at the start the crash didn’t happen. I considered if the game was paused or not while writing this my feeling is when the game was running there was no crash i.e. it only happened when paused but needs rigorous testing to confirm.

When I start a new play-through now I am aware of this (will the game crash the first time i click the research screen?) but have not had it happen yet in 1.31 though I have only started a couple of new missions since 1.31 trying to get a feel for the balance changes over the game as a whole.

[Edit] I thought i’d make an effort to try and replicate it in 1.31, the first time I tried it didn’t happen, So i thought I would quit the game and try again (check if the crash only happened from a fresh game start) but the game crashed on quitting! :confused: Will check and post bug report if not already noted [Edit]