[Fixed 1.05][Bugs 1.02] Stuck in R&D and more


#1

Hi Cliff,
had 2-3 hours for playing, these are the results (not mentioning what others already come up with :slight_smile: )

  • i got stuck in the research tree screen two times. Like, I tried to click on the X to close the tech tree, but instead of closing, the start aircon research notification came up. I closed the mini notification, since i was already researching something else. Then tried again the big X in the top right, and it happend again and again… after 5-6 tries, i randomly started other researches, and then i was able to quit the tech tree gui.

-Well, autosave crashed once, and made the autosave file corrupted. I tried to load an earlier manual save, and that was corrupted too. I had to go back 3 manual saves, until i was able to open succesfully. Big save file issue?
For autosave, may I suggest you a double save file system? So, there is always two autosave file at the same time. And you always overwrite the older one. So, if the autosave fails, i got the probably perfect, 5 minute earlier version, which is acceptable.

-The cars pathfinding is still not perfect. They prefer to join a waiting line of 6-8 cars (meaning about one minute waiting), instead of travelling 12-15 tiles for an empty slot. They usually switch lanes, when the waiting line is filled up until the diverging point.

-The fit valves is still my biggest bottleneck. Doesn’t matter how many parallel slots I do for this, the resources just can’t get there fast enough, to give 8 valves for a car.

-If I modify a mission in the new game menu, and delete some import/exports slots and factory parts, then hit esc, like cancel, they are still get missing, the changes are saved :slight_smile: They came back if I restart the game.


#2

Hi, some of these will be fixed in the next patch, is this currently 1.02? I thought I’d fixed all of the ways in which the being stuck on the R&D screen could happen, but maybe not! I suspect its a dialog box that is ‘underneath’ which prevents it responding to the mouse, but hitting the escape key should do it.


#3

I’ve gotten stuck in the R&D screen a couple of times in 1.02, and escape will get you out. Each time, there was something open below it (which I’m guessing was stealing the mouse clicks).


#4

Yes, it was 1.02


#5

Hi Cliff! Daily report :slight_smile:

[1.02]
-I got a new bug in financial graphs. The income bar just keeps showing 0, but I do make money, since my capital is rising. See attached screenshot, and savefile.

-I did a crash with conveyors placing.
One car conveyor was going one tile in front of an unused import slot place. I temporary deleted the conveyor, placed the importer. When I rebuilt the car conveyor, it crashed when a car arrived there. See explaining image attachment.

I know you are working on it, but still can not open large save files :frowning: A little disappointing, that I lose my very nice factories :slight_smile: I hope the files are not corrupted, just the loading fails.



6be_noincomegraph.zip (421 KB)


#6

[1.02]
I started to play around with the factory layout designer.
I did drag a new zone from the bottom left corner. It resulted in two wall lines, with no area in between. I see now, that i should drag only from top right. But it’s too late. I can’t delete the defective zone. And what is more interesting, i can’t start a new game, got the attached error. :slight_smile: I guess reinstall solves the problem.

EDIT:
I was able to manually delete the entry from the text file. Also turned out, that the crash occures, when there is no floor type assigned. Which can’t be made on the GUI right now, so i just copy the floor texture line to each zone, and its working :slight_smile:

EDIT2: It’s crashing because the LOCKED/UNLOCKED was not selected, not the floor type.





#7

I’m fixing the finance bug right now. I’m not prioritizing the level editor at the moment (its very buggy).
I’ll also look into the crash thing!


#8

Placing a dedicated stockpile helped me alot, prefarably with an import slot close that´s not too heavily used.
I wanted to sort this by having valves manufactured but it´s looks like it´s a bug in the menu that prevents us from doing that.


#9

i think that also got fixed today.