A bug I'm fixing, and a workaround


#1

Ok, just had a bug report in the latest version. if you get this error when loading a game:

"Could not find job:..\src\SIM_JobBase.cpp 507"

That’s it. I hope to have a fix today. but in the meantime, you can either email me a broken save and ask me to fix it, or do this:

Open the save game using a text editor like notepad (savegames are in MyDocuments/My Games/Kudos2 /Savegames

search for

then delete everything inside and leaving just this:

<jobs_offered> </jobs_offered>

Then it will work.


#2

Hello!
I’m new to the Kudos games and I love them!I have only been playing a week or so but I’m having the problem that you said about here and I have tried to fix it by going into the savedgames folder but it’s still not working! I was wondering if you had anymore ways of fixing this problem please?
Many thanks!
Kudosgirl81


#3

Hey Kudosgirl81. How smell the roses?

Be sure to have the latest version of the game as this has likely been fixed in one of the patches. I believe the latest version is 1.05.
viewtopic.php?f=17&t=2000

The patches are incremental so if you have version 1.03 then you will need the 1.04 patch AND the 1.05 patch. The game version can be seen at the top right hand of the Main Menu screen (eg. Final 1.05).

If you have any more queries, just let us know :slight_smile:

Wayno, accomplished, cool TV chef


#4

Hi SomeGuyInABikini!
Thanks for your help! I do have the latest version final 1.05 but now my game is doing this even when I start a new game so I can’t play kudos 2 at the moment so I’m back playing kudos 1! I might reinstall kudos 2 and see if this happens again!
Thanks once again!
kudosgirl81


#5

Hello!
I just wanted to say that I have fixed my game! Yeah! I had sometime today to look into this.
I didn’t know that when you open the file you want to correct that you then had to go to view source. So now using the workaround I can play Kudos 2 again!
Thanks to everyone who offered me help!
kudosgirl81


#6

Helllloooooo to you!
I’m glad you got it to work, but your original problem begs the question: Just what program are you using to view the CSV files? It sounds like you’re using a web browser, which I would recommend against. Try using something like Notepad (not Wordpad).

Either way, good to see it’s working :slight_smile:

Wayno, all Caesar Salad’d out