Demo Crashes


#1

I’ve tried the demo on 2 different machines and one won’t start at all, the second runs for awhile and then crashes. The game looks interesting from the little I have seen of it, and I’m set to purchase it if I can get it to run. Listing specs so you can see if anything stands out as a possible incompatibility.

Machine 1, E6850 dual, 3.0ghz Server 2008 64, 4G Ram, NVidia Quadro FX 1700, no sound enabled on the machine, latest drivers. Clean machine install 4 weeks max (New machine and new drives), with Server tweaked for workstation\everyday gaming use. 1920 X 1200 rez on monitor
I get black screen and then an error when trying to start the game that it needs to close. I tried compatibility mode and it didn’t make any difference.

Machine 2, Q9650 Quad, 3.0ghz Vista Ultimate 64, nvidia 9600 gs2, 4G ram, Latest drivers, on board sound Supreme FX X-Fi audio card, 2 weeks ago clean install on new hard drive, so all latest patches, etc. Runs for a short time and then same error as above. I was able to get through the demo to the part where it has you click on the party buttons. Or the button after that. 1920 x 1200 rez on the monitor, haven’t checked the game settings

I’m running the demo downloaded from Impulse.
Is my problem 64 bit?


#2

I’ve got it running on 64 bit Vista Ultimate. Stardock can be a bit tricky when you use their Impulse software to get stuff.

Even if you think that you’ve got an administrator account, try setting the rights to run the program as an admin user. That solved a bunch of problems that I was having.


#3

Was worth a shot, but no luck. I’m logged in as admin, but I figured I would try it anyway. At least I know it isn’t the 64 bit that is causing the problem.
This computer, the one that won’t even allow it to start is a software development machine. Maybe it doesn’t like something installed on it. The other machine is straight gaming only and I’ll just say I’m a game a holic and so it definitely doesn’t usually have problems running games.

Is it possible there is a newer version of the demo out? I figured StarDock would have the latest.

Donna


#4

I found the problem with the Server 2008 machine. Windows sound service was turned off. I started shutting down apps from the tray and noticed an unfamiliar icon. I guess it won’t run without sound. Now I can play while I’m supposed to be working.
As for the second machine, no idea on the problem with it. I was able to pay through the demo last night using it, so I guess the problem is not going to be a big deal.

Fun game, even though I’m not very good at it. 9% popularity when the demo ended… Time to go purchase a copy.

Thanks
Donna


#5

Stardock doesn’t always have the latest version… I bought Democracy 2 through Stardock, but have since purchased the rest of the games directly from clifsky. Since you’re also running a 64-bit version on Windows, this tip may save you a lot of aggravation later on: A Stardock archive made on a 64-bit machine cannot be used on a 32-bit windows machine, and vice versa. I was having HUGE fits trying to get the archives on my old WinXP machine onto my new laptop…I finally got tech support to admit in the forums that you can’t transfer their archives between 32 and 64 bit versions of windows. The versions you download direct from Positech can be used on either 32 or 64 bit versions, which is a big plus.

Getting back on track (more or less) you can use the update patches on this site to upgrade the Stardock versions. Just make sure you get all of the intermediate ones or something may not work properly. For example, you would need the patch for 1.21 to 1.22 as well as the patch to go from 1.22 to 1.23 if you want to upgrade from 1.21 to 1.23.


#6

Thanks for the heads up. I came here through google, didn’t even notice the main site.
I just bought my copy directly from here.

Thanks,
Donna


#7

Glad to help you out…and welcome aboard!