Democracy3.exe has a problem! Cliffski please help!!!!


I purchased democracy 3 from steam yesterday and can’t get it to run, I have tried everything I can find in forums and internet please help…

Kind Regards


Cliffski is super busy, so asking for help but not telling him the full story is not going to be useful for either of you. To help him better understand your problem, you need to provide more data for him than you did above. A few key points would include:

What computer operating system are you running? Exactly which version of it do you have?

Is your OS 64-bit or 32-bit?

What action did you perform in the game immediately before the crash?

What was the exact text of the error message that appears when your game crashes?

(You already mentioned that you’re using the Steam version of the game.)

I do not play Democracy3, so hopefully other D3 players may possibly be able to offer some advice to you until Cliff sees your post here. In the meantime, hang tight and be patient. Thanks. :slight_smile:

The issue that everyone seems to be having is that no matter what OS (although I suspect most of us are Win 7 or 8 64 bit), when playing you are lucky if the game allows you 4 turns. You implement policies, change policies and it locks up completely, requiring Task Manager to kill the game. There are times when even Task Manager won’t kill it, and you have to go into the Processes tab to kill the .exe file to kill the game.

We have tried all sorts of methods of correction… disabling mods, playing in offline mode, uninstalling and reinstalling, etc. and we can’t seem to get past (at most) the 4th turn.

The game played very well until there was a Steam update around the end of June. We all love the game and are desperate for a bugfix. The Steam forums will spell it out as well.

Help! PLEASE!?

I’m trying to reproduce this now, but cannot. Is it only happening to steam copies?

Right then… I may have a fix.
If you right click the name of the game in your steam list of games and select properties, then select the BETAS tab, then in the drop-down list select pc_beta, the game should then do a minor update to 1.151. This MAY fix it. PLEASE tell me if it does, or if it doesn’t (posting here is fine). If so, then I will roll this out to everyone./ There is no loss of functionality, it’s just an under-the hood thing.

Is there any news about this? Even with the beta version, it doesnt work for me. The very same problem as Dichotomi described.

Can you email the debug files from /my documents/my games/democracy3/debug to cliff AT positech dot co dot uk, with a link to this thread?

Okay, is done. Hope you can help.

Has there been any progress on this issue?? All of the users who use the steam forums have essentially be left in the dark, and this patch doesn’t work.

A lot of us experiencing this problem appear to be first time buyers…cant see many of us doing repeat business at this rate though.