Extremely Slow game/cursor


#1

I initially tried the game out via WildGames’s portal, but it was running extremely slowly. Not the load time, but the cursor itself would “jump” around and take seconds to move from one location to another. Hitting “next day” could take minutes. Etc. I liked what I saw, otherwise, so I tried the demo from the website directly, since it appeared to be a slightly different version. It’s better, but it still has the same problem. I’ve turned off the weather effects & background, which helped a bit. However, it definitely has the feel of a memory leak. I’m running XP, btw. I shut down a bunch of background stuff, etc, no help. I’d be interested in buying it, but this problem is making it unplayable right now. Any ideas?


#2

Hi, the game definitely does not have a memory leak. What video card and processor (CPU) does your PC have?


#3

AMD 64 3800+
2.41Ghz, 1Gb RAM

Radeon X1600/1650 (I forgot which and apparently it doesn’t bother to tell you which anywhere).

Windows XP Pro, running with admin priveleges.

My default resolution is 1280x1024, dual monitors.

I actually don’t have the latest video drivers (Radeon has new ones as of January or so). I had them, but I rolled back because it was crashing Simcity Socities (great idea, when it WORKS, grumble). I might give that a shot, but I’m fairly sure the drivers post-date the game. OTOH, it didn’t fix Simcity, either (rolling back), so I should probably update to the latest either way.

Does it install everything locally, or is some data put out on My Docs? My Docs is out on a server on my setup (just trying to think what it might be), but that’s usually not a problem.

Not sure what else, but let me know if you want any other info.

Thanks!


#4

Aha, the game does stick a few things in MyDocs, but as I recall, nothing at all that it would need to access on a regular basis, or which would explain any slowdown.
Kudos uses windows GDI to draw it’s text, which is a bit unusual in games and it might be that certain drivers don’t cope very well with the mix of directx and GDI. have you noticed the problem get worse when there is more text onscreen?
If you can right click the games icon and select compatibility options, it might be that fiddling with those settings would fix it. The game should be smooth as silk on your hardware.