Failed to initialize 3D engine


#1

A little help please;
When I try to start the game, I get an error message that says “failed to initialize 3D engine”. Here is a copy of the the debug error log. Any help would be great. Thanks…

21/11/2010 - 6::7 - Failed to initialise 3D Engine:…\src\Game.cpp 309
24/11/2010 - 3::36 - D3DERR_INVALIDCALL
24/11/2010 - 3::36 - CreateDevice
24/11/2010 - 3::36 - D3DERR_INVALIDCALL
24/11/2010 - 3::36 - CreateDevice failed again
24/11/2010 - 3::36 - Failed to initialise 3D Engine:…\src\Game.cpp 321
24/11/2010 - 3::44 - D3DERR_INVALIDCALL
24/11/2010 - 3::44 - CreateDevice
24/11/2010 - 3::44 - D3DERR_INVALIDCALL
24/11/2010 - 3::44 - CreateDevice failed again
24/11/2010 - 3::44 - Failed to initialise 3D Engine:…\src\Game.cpp 309


#2

Did you just install it? I remember hearing from a friend that this problem could be fixed by deleting the ‘my games’ gratuitous space battles folder (the game will recreate it when launched). It’s worth a try if you just installed.


#3

Cleared it up… Thanks…


#4

Glad that helped!!

Welcome aboard Captain…I hope to see your fleets in battle.


#5

this happened to me just as i installed it today. i cant even start it up but i get the same message. now i have gone and deleted my folder like you said but then it gives me a different error message when i start it up again


#6

after deleting the folder i get the error message:

error - fmod[failed to init fmod] (58) error creating hardware sound buffer.
:…\src\gui_sounds.cpp 661


#7

What are your pc specs, do you have a sound card on that PC?


#8

I’m having a similar problem. I’ve tried deleting the folder and also changing prefs.ini. Same error returns in each case :frowning:


#9

I have the same problem than him with a sound card that’s in integrate in the mortherboard.
Realtek mortherboard.

And the game have already launched in December, on my first installation.


#10

Greets… i have the exactly same 3D Card Problem with the Game and since i got it over Steam i just Hope i can get it fixed before i will lose the money i have spend for it… i also tryed the deleting the ‘My Games’ folder and got the strange :…\src\gui_sounds.cpp 661 note now… please can anyone help me with the correct repair to get the game running?


#11

have you tried deleting that \mygames\gratuitous space battles folder and then re-running?


#12

Yes allready tryed that out and it still don’t runs… since days i’m now seeking a way to get the Game starting… haven’t known it needs any specifications in Soundcard or Graphic… sights Hopefully my Money is not wasted.
Do you have any idear Cliffski ?..
Or is it normal that a game can cause such Problems to so many Playsers? looks up the logfiles Guess i’m not the first one ^^


#13

I’d been running the GSB Demo on my Dell 1750 with Windows 7. After a while, I noticed a jitter as the game played (video and sound). After a while, it stopped running. Figured there was/is a limit on how long the demo could be played.

Deleted the game and the installer, did file clean ups, and eventually downloaded and reinstalled GSB - would not run, reporting a series of Failure to initialize the 3D engine. Checked my permissions, compared to previous run configs in a restore point - nada. Spent a lot of time looking over the forum only at the Support/Windows 7 area before finally seeing the Failed - 3D option area. Thanks for the suggestion to delete the my games\gratuitous space battle file - this fixed the problem.

Now to see if this repeats the earlier jitter issue with GSB after I run it a while (again).

Bill


#14

Hi everyone,

I fixed this by setting my current video resolution in the prefs.ini file.
Hope this helps.