[Fixed 1.09][Bug 1.08] After an autosave the game crashes


#1

This also occurs when attempting to load a previous save game. Basically, I can’t play version 1.08.



#2

Yeah, I get the crash too on every savegame that is from 1.07 or before. 1.08 doesn’t seem to like any of the existing savegames.

Not even reinstalling helped me with that. xD

Somehow I was expecting that because Cliff changed some leaks to fix the resource pending bug which probably where the older savegames had a lot of dead weight caused by leaking information from one map to another map due not correctly freeing up stuff when going to the main menu.

Guess it’s time to start a new map… :smiley:


#3

I cannot even start a new game. After a couple of minutes it just crashes.


#4

Yikes. is this happening with new savegames from newly started maps? or just old ones. I did specifically test it with older games :frowning:

edit: just checked again loading up an old save game, and it seems fine :frowning:


#5

Sorry! Just got it working. Needed to delete all old saves to get new ones working.


#6

Here are my error logs when trying to load a 1.07 savegame:

errors.txt (173 Bytes)
drawdebug.txt (848 Bytes)
debug.txt (300 Bytes)

I’m still testing to build a factory for 1.08… If I run into any savegame errors or other errors I’ll post them.


#7

Gah… when it does this

14/2/2017 - 16::55 - Assertion failure:filename:…\src\GUI_TextureCache.cpp,linenum:25

can you not just ignore it and carry on?
I don’t see why it isn’t triggering for me :frowning:


#8

I have been playing for about half an hour now and after deleting all old save files I have not got an error. (Plus when that error comes up it forces you to quit the game)


#9

issue.

wont complete save. breaks savegame???

missing tag: out:…\src\SIM_loadGame.cpp 1276

how can we edit our money in the savegame file? you like tranfer it to a new savegame with research :slight_smile:


#10

I started a new game with 1.08 and I can confirm that the game crashes when autosaving.


#11

Can someone post one of these broken and aborted saves?


#12

Yup, just got an error after playing for a while. When it auto saved it crashed on the Saving Stock and now it wont load when it gets there. Will post a save in a sec.





#13

Yepp… forces you to quit the game.

Developer nightmares… I can relate to them.



#14

Here is a save…
autosave.xml (194 KB)


#15

Hi,

Just bought the gave and I have the same issue. After playing a fiew minutes when it saves the game will crash at the stock saving phase. The crash force you to quit the game and then you won’t be able to reload it because the autosave is corrupted at the stock phase again.

Sorry about my english, I’m french… :slight_smile:

Just frustrating I was looking forward to play this !


#16

… So I found out that it even happens while playing with a new 1.08 map and not only with 1.07.

About 30min into the game the game tried to autosave and crashed while doing it… again with:

Assertion failure:filename:..\src\GUI_TextureCache.cpp,linenum:25

#17

Ok, I think I fixed this… The new installer is now called PLInstaller108a.exe, but this time it shouldn’t create screwed up autosave games :frowning:
It wont fix corrupted games, but it wont create new ones (hopefully)


#18

Have been playing for about 5 mins and no errors so far. Going to have to go soon but all is looking good! Will say if the problem persists. Thanks!


#19

Same for me, it seems to work ! Playing about 15 minutes no problems with autosave. Thanks :slight_smile:


#20

Actually it says 1.09 inside the main menu instead of 1.08a… so you might want to take into consideration when creating the next version… the next version should be called 1.10 then because otherwise it would cause confusion. xD

That or you will have to upload another updated version of the installer with the correct version number being displayed in the main menu.