[Fixed 1.05] [Bug] crash - autosave


#1

Hi Cliff,

I got this crash out on autosave, not sure if the pic helps to show the processing point or not.

postimg.org/image/ckub5zf9t/

This, i think, was caused by being alt-tabbed out of game when it decided to autosave - i tabbed back in mid save and it immediately crashed.

Regards,


#2

oh yikes. it should do saving ‘atomicly’, ie: not allow itself to be interrupted. It may well be something else. Was this maybe a HUGE map that had gone for a long time? or possibly one where you had maybe dozens of different car designs all being created at once?


#3

There are two options:

  1. There was a max of only 1 car model being worked on, there might have been but probably wasn’t another obsolete model.
    This would have been in the largest map size, but with no extra space unlocked, run time definitely sub 2 hours.

  2. The second largest map size, and the only stuff on the map was R&D labs as i was trying to replicate the bug i logged in “bug - visual glitch - build list”, the only stuff on the map is visible in the screenshot on that post.

I suspect it was in (2) but would say 80/20 odds. (the fact that that post references finding another bug and was posted 3 minutes before this one is my guide there :slight_smile: ).


#4

Also got a crash during auto-save. I was in the middle of placing an equipment and clicked right as it auto-saved; not sure if it’s related or not.


#5

Auto save seems to crash after at least 5 saves, corrupting the save file.
autosave.xml (109 KB)


#6

Joining in to this topic, that CTD isn’t limited to the autosave, it also happens to manual saves.

I >>Guess<< it might have to do something with the amount of buildings placed / Items on the scene.
I just finished a production line, that should be able to produce 1 car per 4 seconds when the autosave caused a CTD.
I could load the previous save just fine, did the same changes again, tried a manual save and the manual save also crashed. (unfortunatly, silly me tried to overwrite the manual save >_< )
Played for roughly 90 minutes on this.

Edit:
Rebuild most of the factory, again crashed & corrupted savegame after roughly 90 minutes.
Added last working savefile as attachment as well (save1), crash occured ~10 minutes later.

(I must admit, I cheated some money in the 2nd one to get to that size again faster)

2nd Edit: I reloaded the save an hour ago, and i could play just fine for more than an hour without any crash.
The crash might have something to do with some timer stuff or maybe an memory-bug - also added the latest savegame as well (save1_new)
(if the attachments become to big, I could delete the older ones)
save1_new.xml (1.92 MB)
save1.xml (1.33 MB)
nizh9.xml (232 KB)