Maintenance Problems in Campaign


#1

Something seems to be wrong with the method of generating maintenance in the campaign. I have just attempted to play my first campaign and found it impossible. I had taken a small empire and I had two small fleets protecting my borders, each of which was too small to attack and capture any more planets. However, my maintenance was already more than my income, which I thought was strange as my fleets were pretty small. I decided to attack with one fleet and, predictably, it was destroyed. However, the maintenance barely changed and I was still broke, despite being left with only one small fleet. The next turn, it too was attacked and destroyed and again, the maintenance stayed roughly the same. Now I had no ships and the maintenance still did not budge. The next turn the maintenance finally fell, however despite not having a single ship under my command the maintenance still won’t go below 244.

Looking in the debug file, the game is calculating maintenance on 8 ships:

Main calc: 42.492001 (cost 2832.800049 fact 0.015000 quan 1 Main calc: 42.492001 (cost 2832.800049 fact 0.015000 quan 1 Main calc: 38.435997 (cost 2562.399902 fact 0.015000 quan 1 Main calc: 30.006001 (cost 2000.400024 fact 0.015000 quan 1 Main calc: 9.093000 (cost 606.200012 fact 0.015000 quan 1 Main calc: 30.006001 (cost 2000.400024 fact 0.015000 quan 1 Main calc: 53.219997 (cost 3548.000000 fact 0.015000 quan 1

It may be coincidence, but the prices of those ships seem to be roughly the same as some of the ship designs I used in the campaign. It seems that the game is calculating maintenance on ships that have been destroyed.