Save cannot be deleted


#1

I downloaded a save file (the one posted on 16 Sept) from this thread to look at how other players do things but that particular save cannot be deleted afterwards for some unknown reason. Nothing happens when I click the delete button in the save/load menu.

I also downloaded 2 saves from another thread which I was able to delete without any problem.

I tried to delete it from the local save folder but steam cloud sync will simply re-download that undelete-able save to my local save folder whenever I run Big Pharma.

Renaming that save file in the local save folder will create another undelete-able save.

The only solution I can come up with so far is to delete the local save file and disable steam cloud sync.

Not sure what is causing that save to be “immune” to delete, so I am reporting it here as a potential bug.


#2

I think this is probably to do with a missing thumbnail. Every savegame should always have a thumbnail of the same name next to it in the save folder. If this is missing, it might cause an error when you try to delete it.

To solve the issue, always copy both the save file and the thumbnail when sharing games. If someone does not provide a thumbnail with their save game, you can just create a “dummy” one with the correct name, which should allow you to delete it via the normal method in-game.

Having said that, next time I do an update I will make it so that if a thumbnail is missing, you are still able to delete the save.

Regarding your issues with cloud save. You can get around this by manually deleting files while the game is running, this will trick cloud save into thinking it was the game that made the changes and will therefore respect the changes and alter the cloud version accordingly.

Hope that clears everything up,

Tim