[Solution] Unable to select Alliance or Empire races


#1

I have completed the single player game on all difficulty settings, I believe I was running version 1.03 when I beat it. All races were unlocked.

With version 1.04 the Alliance and Empire races are no longer available to me. I was the Alliance before the patch, and still have that selected as my race, but the option to choose them is grayed out. I can load alliance ship designs previously built, and save ship designs to a new file. I can not select hulls from the Alliance or Empire.


#2

I looked into this a bit more, found a solution!

There is a file named “sc.dat” located in documents and settings, so for example my path is:
C:\Documents and Settings\Erlandr\My Documents\My Games\GratuitousSpaceBattles\sc.dat

This is just a text file, so I loaded it into notepad++ and discovered one entry that looked like a level I hadn’t beaten:

[baleur_bloodbath]
beaten_easy = 1
beaten_medium = 0
beaten_hard = 0
highest_honor_easy = 0
highest_honor_medium = 0
highest_honor_hard = 0

This level isn’t selectable in game, but the entry here prevented me from unlocking the two races. How did I beat this on easy? I don’t know…

Anyway, filling the beaten_ values with 1 instead of 0 worked, also just deleating the whole baleur_bloodbath entry worked. I chose to stick with the latter, because baleur bloodbath didn’t appear in the newer sc.dat file the game created (To have the game recreate the file, I just renamed the original file) :slight_smile: