Startup bug[1.12]


#1

Currently, if I try and startup GSB, I get a flash of the normal loading screen, then it goes grey, and I get a “GSB.exe has stopped working” message, with no additional information. After uninstalling and reinstalling GSB, the only difference was that the first time I tried to start up GSB, the text box only said “Error File:”. I’m on a Laptop running vista. Any idea what’s causing this? Or is their any information that you need first?


#2

Check in your “Program Files\Gratuitous Space Battles Beta\debugdata” folder and post the contents of all of the files (debug.txt, debugdraw.txt, errors.txt).

Also, if you get the “GSB.exe has stopped working” error again, there should be a button that says More Info. That stuff might be helpful to Cliffski.


#3

There isn’t a button that says more info. It says “Windows is checking for a solution”, and the only options you have are to cancel it, which simply closes everything, or to let it continue, in which case it says “a problem cause the program to stop working correctly. Windows will close the program and notify you if a solution is available.”, and the only option it gives is to close the program.

The errors.txt is blank.

The debug.txt contains the following:
----DEBUG FILE----
Windows Vista detected
GSB Debug File. App version Beta 1.12
Desktop resolution is 1440 x 900
Initialising Direct3D
Initialising global vertex buffer
creating render targets
success in initialising 3D
Checking for application update

GSB

response,true,

message,gratuitousspacebattles/server/patches/3338755341722/GSBBeta112.exe

Initialising Direct Input
Finished Initialising Direct Input

The debugdraw.txt contains the following:
Initialising 3D Engine
Driver : nvd3dum.dll
Description : NVIDIA Quadro NVS 135M
DeviceName : \.\DISPLAY1
About to Create 3D Device with width: 1024 and height : 768
Checking For Shader Support
NumSimultaneousRTs:4
hal_caps.PixelShaderVersion >= D3DPS_VERSION(2, 0)
Finished initialising 3D Engine
Initialising Render target of 512 X 512 rt_ship
rt_ship
Initialising Render target of 2048 X 1024 rt_offscreen1
rt_offscreen1
Initialising Render target of 2048 X 1024 rt_offscreen2
rt_offscreen2
titlescreen1024.bmp

Thanks for the help.


#4

Okay, I found where it was sending the error reports, and this is what it says:
Problem Event Name: APPCRASH
Application Name: GSB.exe
Application Version: 0.0.0.0
Application Timestamp: 4aa67c2b
Fault Module Name: GSB.exe
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 4aa67c2b
Exception Code: 80000003
Exception Offset: 000050ab
OS Version: 6.0.6001.2.1.0.256.1
Locale ID: 1033
Additional Information 1: 4ad8
Additional Information 2: ff73d95308158bf3ae357d432aed1685
Additional Information 3: 50f3
Additional Information 4: c1a1ce059452a26ee30690ae3af42037


#5

Very strange. I take it the game used to run ok on this laptop? Can you uninstall again, and this time totally ditch the folder called \MyDocuments\My games\Gratuitous Space battles (or rename it if you want to copy over ship designs later).
The only thing i can see that might be crashing there, without any hints would be initialising the tutorial in some way. It looks like the video card is perfectly happy.


#6

Thanks. That seems to have done the trick.

Granted, now I need to beat the game again and get all my honor back. Oh well, more reason to play it.