Game no longer works on startup as of 1.37


#1

The music starts and I get the splash screen with the Imperial ship, but the game quickly quits and I get a message reading “GSB.exe has stopped working. A problem has caused the program to stop working correctly. Windows will close the program and notify you if a solution is available”

I’ve tried reinstalling and running as an administrator.


#2

I am assuming that you are running Windows 7 ?

Also when you reinstall, do you first remove the content contained in My Documents ? (ie ship designs, downloaded challenges etc)


#3

vista x64, and no, I did not remove that stuff.


#4

There’s a debugdata in the game directory. There should be some informations in the logs.


#5

I’m using the demo of the same version (I’m one of those guys who like to try before they buy :P) on windows 7 and I’m getting something very similar to the situation above. I start it up and the game goes to a white screen, no sound, nada, before crashing for some unknown reason.

I can’t find any debug files, so I can’t say as to why the game crashed, but I’m just saying that it doesn’t seem limited to Vista.


#6

Its definitely worth trying to rename the \my documents\my games\gratuitous space battles folder and then restarting the game. It should definitely work then, because its effectively a new install then. If it still hangs, it could be firewall related, although even if a firewall blocks the game, it should still run fine. And AFAIK, the demo doesn’t make any net connection attempts then anyway.


#7

Thanks. I tried renaming the folder; still doesn’t work. It created a new one. Here’s drawdebug:

Initialising 3D Engine Driver : nvd3dum.dll Description : NVIDIA GeForce 6150SE nForce 430 DeviceName : \\.\DISPLAY1 Checking For Shader Support NumSimultaneousRTs:4 hal_caps.PixelShaderVersion >= D3DPS_VERSION(2, 0) About to Create 3D Device with width: 1440 and height : 900 Attempting hardware Vertex Processing Finished initialising 3D Engine Initialising Render target of 512 X 512 rt_ship rt_ship Initialising Render target of 2048 X 1024 rt_offscreen1 rt_offscreen1 Initialising Render target of 2048 X 1024 rt_offscreen2 rt_offscreen2 Initialising Render target of 2048 X 1024 rt_transition rt_transition titlescreen2048.bmp cwfont20.dds zekton16.dds

And here’s debug:

[code]----DEBUG FILE----
Windows Vista detected
GSB Debug File. App version Full 1.36
Desktop resolution is 1440 x 900
Initialising Direct3D
Initialising global vertex buffer
creating render targets
success in initialising 3D
Initialising Direct Input
Finished Initialising Direct Input
Initialising Sound Engine
Initialised Sound System with 512 channels

Finished Initialising Sound Engine
[/code]


#8

If i may make a crazy suggestion . .

Go to your install directory and rename GSB.exe to GSB.bak
find the 1.36 patch and extract it to a trash directory.
grab the GSB.exe from the trash directory and place it in the install directory

don’t let it update - but see if you get the same problem


#9

I’m really not sure how to do any of that.

So, there’s the C:\program files\gratuitous space battles folder that has the GSB.exe and also all the nuts and bolts.

Then there’s the C:\my documents\my games\gratuitous space battles folder that has all my saved data, ship designs, etc.

You want me to go into the program files folder and do what exactly?


#10

Sorry that took so long, Ok, please note that this is a long shot. .

  • Open up “C:\program files\gratuitous space battles” and rename GSB.exe to GSB.bak ( if you cant see the extention of GSB then rename it to gsb137, we just need this file out of the way for awhile )

  • Open up “C:\my documents\my games\gratuitous space battles\patches” and look for GSBPatch136.exe

  • Run that program but when it asked for the install location, change it to c:\trashme

  • Once complete, navigate to “c:\trashme” and copy the GSB.exe to “C:\program files\gratuitous space battles”

  • delete the “trashme” directory

Run the game.

If it works then sw33t.

if not then delete GSB.exe from “C:\program files\gratuitous space battles” and rename GSB.bak to GSB.exe
that will bring the game back to what it was before you tried this crazy idea


#11

There is no patch 1.36 in the patches folder. There’s a 1.37, but no 1.36.


#12

I am a meathead - I just realised that your install is version 1.36
just reinstall the game and don’t let it patch.

If the game works with that version, then we can them move on to plan B


#13

How do I prevent it from patching? It stops working before it even prompts me. To clarify, I’ve uninstalled, reinstalled, and it still won’t start and I’m still getting the same error as before, and before any patching has occured. I’ve tried adding an exception to the firewall, and it doesn’t work. I’ve tried turning the firewall off, and it doesn’t work. The demo still works.


#14

So you have reinstalled the game and it still wont work ?


#15

Yep, three times now. I’m wondering if this has something to do with the recent Windows updates I had forced upon me by MS, or if my installer is somehow borked.


#16

Damn . . Well to test the borked installer, redownload the game . . and try.
As for the recent update from Microsoft . . i am at a loss, my suggestions now are along the lines as

  • Virtual machine inside vista
  • or run GSB as a 32bit

#17

Where can I redownload the game from?


#18

Did you buy the game through steam or through the GSB website ?


#19

GSB website.


#20

Cool, then you would have recieved an email with the download instructions and a link
Hit that link again . . it looks something like this download.bmtmicro. . . .