Windowed Mode Problem


#1

So… I’d first like to say that yes, I did do something stupid.

I got a new monitor so I wanted to switch to a higher resolution. I also didn’t want to use the fullscreen mode. What I forgot to check was whether the new resolution I picked for my window would actually fit on my monitor, which it didn’t. The bottom of the GSB window goes off the bottom and I can’t drag the window enough to get to the bottom to change the options. Especially doesn’t help since I’m on Windows 7 and it insta-snaps everything to the top edge. Is there a hotkey to make it fullscreen again? I don’t mean fullscreen window, I mean actually full screen so that it fits everything into the space provided so that I can actually access the button on the bottom of the screen, namely options so I can change it back!

Alternatively, is there a way to edit any files to change my resolution back down?


#2

Oh. I fount a way to fix it, but it was much harder than it should’ve been. Had to switch the whole monitor setting to portrait, as opposed to landscape, mode. This made it so i could see the bottom of the GSB window, then I could get to options and pick something that would have the right resolution for me to see it once I was back in landscape mode. It’s complicated and I can’t believe it actually worked.


#3

Yep, you could have edited the prefs.ini file in my docs\my games\gratuitous space battles\


#4

when i go to windowed mode, part of the menu options get cut off at the bottom (it helped to move my taskbar to the left side on my monitor), but window’s still has this thing where it likes to think there’s desktop way off the margins of the monitor.

i haven’t cared enough to look into it, but i’m running the max resolution my monitor can officially handle.


#5

Ok this just happened to me too. How do I edit the file. Like what do i put?


#6

~/My Games/GratuitousSpaceBattles/prefs.ini

Open the file with a notepad or similar text editor.

Change the number for the resolution you want.

To have the game windowed change 0 to 1


#7

Allright, its fixed. Thanks!