[BUG] weird bug after today's update (0.41.00)


#1

After updating the game today I now had the same issue three times. I play a mission (doesn’t matter which one) and after half an hour ingame the game stops. The employees still “move” and do their stuff but nothing else. My earnings go into the red and I can’t sell anything anymore. I can’t save, I can’t do anything, only possible thing is quit the game and restarting, but if you didn’t save in between, you are doomed.


#2

I just had the exact same bug, I think it happened after a piece of research finished :S


#3

Yes, exact same here. It indeed seems to happen after finishing some research but can’t confirm it. Perhaps time for autosave as well?


#4

Can confirm. Happened twice.
Also note, that once in this state, you cannot save the game (click the Save button and no result).

gif of the behaviour: gfycat.com/FlakyFamousAfricanclawedfrog


#5

I had exactly the same issue too. The timer continues to go (or at least it continues to calculate earnings), but nothing else works.

Here’s what I tried:

  • Replace existing saved games (no reaction)
  • Delete saved games
  • Remove / put back bets
  • Stop / start importing ingredients
    The last 3 actions did work, but the game remained stuck.

#6

Can confirm too. Happened to me too. Annoying that you can’t save and reload the game, so I had to start over.

I’ve created a dump file if that helps you:
[HIDDEN LINK AFTER DEVELOPER DOWNLOADED IT]

Same bug is also reported here:
viewtopic.php?f=50&t=11424


#7

sry, didn’t notice that this was the same bug


#8

I’m really sorry about this guys. I’ll look into it and try to put out a patch to fix things ASAP. It is probably as a result of some of the optimisations I did for the latest update.

EDIT: Anyone experiencing this bug, can you send your Big Pharma\Big Pharma_data\output_log.txt to me at support@twicecircled.com

Thanks


#9

OK I’ve pushed out a hot fix for this problem v0.41.03. Apologies about the double update, I’m trying to keep it to once a week where possible.

Please let me know if you continue to experience the issue, along with the output_log.txt if possible. I will add an autosave feature in the next update so if I introduce another bug like this in future, it will be a little less painful. I’m sorry for any inconvenience caused. :confused:

Tim


#10

I’m still having this issue after the update. If I delete all the belts and stop the input, they resume for about 5 rotations then stop again.


#11

Just purchased the game so I can’t be sure, but it appears that this bug is still not fixed.

Moving/replacing machines seems to help for a few cycles but they often stop again. Sometimes belts become stuck, but it is usually machines. I’ve also noticed raw ingredients not appearing on the belts before the first machine, yet the belt still moved and the machine processes the empty cycle, when these empty tiles reach the pill printers they create a sugar pill with the same concentration as the raw ingredient. Machines that are stuck display “Processing Ingredients” indefinitely.

Email sent with the log file.


#12

Sorry about that guys, I misunderstood completely what the issue was. Thanks to all the output logs you guys sent over, I think I’ve managed to get to the bottom of it.

Latest version is 0.41.05, please let me know if you still experience it in this version.