Can not play the game anymore


#1

I bought GSB from Steam in the beginning of January. Great game. I tried to play it on 1/24 and I am getting the error: GSB.exe has stopped working. Tried uninstalling and reinstalling, but that did not work. Help!!


#2

what has changed on your PC since you originally ran the game? new drivers maybe?


#3

its a new computer so nothing has changed and i only got this computer in november


#4

same thing happened here, after update it just doesn’t work anymore


#5

what version are both these copies? steam is slightly behind in the updates.


#6

i don’t think steam is THAT behind, but maybe they’re experiencing the problem i had with the transitions? when does the crash happen? does it happen when you click any menu button? there should be something in errors.txt that could help.


#7

well when you look at steam update page it has the last one being 1.27 on dec. 9th and when you go through the computers files (not through steam) it gives you the 1.31, but for me the game stoped working before that update happened (1.31), and even so the update didnt work because im missing the fmodex.dll. now i tried getting this and putting it on my computer but for some reason my computer didnt accept it.

This is the problem: i try to open up the game and the steam window pops up telling me that it is preparing to launch the game. that window closes and the game pops up. i can see the title screen for just a breif second with no music or buttons to click and then it closes on me saying GSB.exe has stoped working.


#8

Hi, you don’t have a missing fmodex.dll. If ou are getting this error, then the game has had a patch or expansion instaleld in the wrong place. The place steam puts the game is different to where gamersgate puts it and where stardock puts it, and where I put it.
The patcher and expansions need telling where you have installed the game, and if you don’t get it right, they will install wrong, and the game will not work right, and that sounds like the problem you are experiencing. The patches get stored in \MyDocuments\MyGames\Gratuitous Space Battles\patches, so you can re run them.


#9

idk, I have both the game and the update from your site and it still doesn’t work

tried reinstalling twice

reupdating once

nothing… :frowning:


#10

I’ve said in my post that you have installed a patch in the wrong place, this is definitely what is going on. Thats the only way you can get that error.


#11

nope… I re ran the updates making sure it’s on da right folder and da same thing still happens


#12

yea i did the same thing gunnyfreak did, the patch is in the patch folder but i still get the fmodex.dll is missing error. i searched my computer in the spot that holds all the .dll programs and everywhere else and i cant find this file. but i dont see why this would be the problem since the game stoped working before this update. and even if the patch is in the wrong place idk where to put it


#13

forget about dlls, its not really the problem.

the problem is simply this:

The patch has been installed in the wrong place.

If it was in the right place, then it would find the DLL, which is in wherever you have Gratuitous Space Battles installed. That will vary depending who you bought it from, and where you iinstalled it, and the patch installer does not magically know where it is. Thus, if you install the patch in the wrong place, the game will not run. A new gsb.exe will be put in the wrong place, and it will not have half the files it expects to, fmodex.dll is just the first one it notes is missing.
Make sure you know where the game is insrtaleld before you install any patches to it. It does NOT matter if you get it wrong, because you can re-run the patch and put it right.
The correct path is PROBABLY

C:\program files\gratuitous space battles (for positech)

C:\program files\positech games\gratuitous space battles (for impulse)

c:\program files\steam\steamapps\common\gratuitous space battles (for steam).

TBH I might just prevent future patches from being installed manually unless its a positech version since everyone just clicks next and then gets confused.


#14

Though I hate to be the cause of additional aggravation, I too am encountering this problem. Specifically, it is stating “Error 36”, and and then says “\src\winmain.cpp 45” However, I have installed no updates, patches, or anything else whats so ever. It just starting popping this up whenever I try to launch. The download I have is from the beta if, downloaded from Positech. Hopefully, this sheds additional light on the situation, as there a vast number of warships that need obliterating out there.


#15

Thats a very very very old bug. If you re-use your original download link, you will grab version 1.31, which is up to date and doesn’t have any of that.


#16

lol. Yes, it has been a while since I’ve managed to get on. Works like a charm now though, thanks.